欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

How do you add it?

程序员文章站 2022-04-24 14:32:19
...

Larry is very bad at math — he usually uses a calculator, which worked well throughout college. Unfortunately, he is now struck in a deserted island with his good buddy Ryan after a snowboarding accident. 

They’re now trying to spend some time figuring out some good problems, and Ryan will eat Larry if he cannot answer, so his fate is up to you! 

It’s a very simple problem — given a number N, how many ways can K numbers less than N add up to N? 

For example, for N = 20 and K = 2, there are 21 ways:

  • 0+20
  • 1+19
  • 2+18
  • 3+17
  • 4+16
  • 5+15
  • ...
  • 18+2
  • 19+1
  • 20+0

Input

Each line will contain a pair of numbers N and KN and K will both be an integer from 1 to 100, inclusive. The input will terminate on 2 0’s.

Output

Since Larry is only interested in the last few digits of the answer, for each pair of numbers N and K, print a single number mod 1,000,000 on a single line.

Examples

Sample Input Sample Output
20 2
20 2
0 0

 
21
21

 

 

dp[i][j] i是目标数,j是要相加的个数

动规方程:dp[i][j]+=dp[i-k][j-1](k from 0 to i)

开始wa了一发,是没有注意到dp[0][j]=1

注意:边角位!

#include <iostream>
#include<stdio.h>
typedef long long ll;
using namespace std;
const int N=105;
ll dp[N][N];
#define mod 1000000
int main()
{
    for(int i=0;i<=100;i++)dp[i][1]=1;
    for(int i=0;i<=100;i++)dp[0][i]=1;
    for(int i=1;i<=100;i++){
        for(int j=2;j<=100;j++){
            for(int k=0;k<=i;k++){
                dp[i][j]+=dp[i-k][j-1];
                dp[i][j]%=mod;
            }
        }
    }
    int n,k;
    while(scanf("%d%d",&n,&k)&&n&&k){
        cout<<dp[n][k]<<endl;
    }
    return 0;
}