已知圆上三点求周长
程序员文章站
2022-04-04 07:59:16
...
The Circumference of the Circle
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 9440 | Accepted: 5474 |
Description
To calculate the circumference of a circle seems to be an easy task - provided you know its diameter. But what if you don't?
You are given the cartesian coordinates of three non-collinear points in the plane.
Your job is to calculate the circumference of the unique circle that intersects all three points.
You are given the cartesian coordinates of three non-collinear points in the plane.
Your job is to calculate the circumference of the unique circle that intersects all three points.
Input
The input will contain one or more test cases. Each test case consists of one line containing six real numbers x1,y1, x2,y2,x3,y3, representing the coordinates of the three points. The diameter of the circle determined by the three points will never exceed a million. Input is terminated by end of file.
Output
For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of pi is approximately 3.141592653589793.
Sample Input
0.0 -0.5 0.5 0.0 0.0 0.5 0.0 0.0 0.0 1.0 1.0 1.0 5.0 5.0 5.0 7.0 4.0 6.0 0.0 0.0 -1.0 7.0 7.0 7.0 50.0 50.0 50.0 70.0 40.0 60.0 0.0 0.0 10.0 0.0 20.0 1.0 0.0 -500000.0 500000.0 0.0 0.0 500000.0
Sample Output
3.14 4.44 6.28 31.42 62.83 632.24 3141592.65
#include<iostream>
#include<cmath>
#include<iomanip>
using namespace std;
int main()
{
double x1,y1,x2,y2,x3,y3;
while(cin>>x1>>y1>>x2>>y2>>x3>>y3)//可以直接表示输入以文件结束终止
{
double a,b,c,p,s,d;
a=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));//求边长
b=sqrt((x1-x3)*(x1-x3)+(y1-y3)*(y1-y3));
c=sqrt((x2-x3)*(x2-x3)+(y2-y3)*(y2-y3));
p=(a+b+c)/2;
s=sqrt(p*(p-a)*(p-b)*(p-c));//海伦公式求面积
d=a*b*c/(2*s);//三角形面积公式s=(a*b*sin(ab)/2),正弦定理c/sin(ab)=外接圆直径d,联立解得
cout<<fixed<<setprecision(2)<<d*3.141592653589793<<endl;//外接圆周长l=d*PI
}
return 0;
}
上一篇: vue函数定义的多种写法
下一篇: vue-《函数定义的多种写法》