HDU 1028 Ignatius and the Princess III(生成函数)
程序员文章站
2022-04-02 23:40:18
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 24796 Accepted Submission(s): 17138 Problem Descr ......
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24796 Accepted Submission(s):
17138
Problem Description
"Well, it seems the first problem is too easy. I will
let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case
contains a positive integer N(1<=N<=120) which is mentioned above. The
input is terminated by the end of file.
Output
For each test case, you have to output a line contains
an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
Author
Ignatius.L
Recommend
We have carefully selected several similar problems for
you:
生成函数的裸题
对于每个数构造一个多项式$ax^i$表示权值为$i$的方案数为$a$
初始时$a$为1
然后全乘起来就行
#include<cstdio> #include<cstring> #include<algorithm> const int MAXN = 121; inline int read() { char c = getchar(); int x = 0, f = 1; while(c < '0' || c > '9') {if(c == '-') f = -1; c = getchar();} while(c >= '0' && c <= '9') x = x * 10 + c - '0', c = getchar(); return x * f; } int cur[MAXN], nxt[MAXN]; main() { int N; while(scanf("%d", &N) != EOF) { memset(cur, 0, sizeof(cur)); for(int i = 0; i <= N; i++) cur[i] = 1; for(int i = 2; i <= N; i++) { for(int j = 0; j <= N; j++) for(int k = 0; j + i * k <= N; k++) nxt[j + k * i] += cur[j]; memcpy(cur, nxt, sizeof(nxt)); memset(nxt, 0, sizeof(nxt)); } printf("%d\n", cur[N]); } return 0; }
上一篇: OJ:又一道考察多态的题目
下一篇: OJ:析构函数实现多态
推荐阅读
-
HDU 1028 Ignatius and the Princess III(生成函数)
-
HDU 1028 Ignatius and the Princess III(生成函数)
-
HDU1027-Ignatius and the Princess II(全排列问题next_permutation函数的使用)
-
HDU 1027 Ignatius and the Princess II[DFS/全排列函数next_permutation]
-
HDU 1027 Ignatius and the Princess II(全排列next_permutation函数)
-
【HDU - 1028】Ignatius and the Princess III(生成函数)
-
HDU - 1027 Ignatius and the Princess II (全排列函数)