欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

POJ 1269 Intersecting Lines

程序员文章站 2022-04-02 17:01:44
...

Intersecting Lines

Time Limit: 1000MS Memory Limit: 10000K

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read “END OF OUTPUT”.

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

题意:

求出两条线的位置关系,相交,平行且重叠,平行不重叠

思路:

先算出是否平行,俩直线叉积为0是平行,重叠就看在平行的基础上一个点是否在直线上,也就是叉积为0的时候。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
const double eps = 1e-8;
double add(double a, double b) {
    if (fabs(a + b) < eps * (fabs(a) + fabs(b))) return 0;
    else return a + b;
}
struct P {
    double x, y;
    P () {};
    P (double x, double y) : x(x), y(y) {};
    P operator + (P p) {
        return P(add(x, p.x), add(y, p.y));
    }
    P operator - (P p) {
        return P(add(x, - p.x), add(y, - p.y));
    }
    P operator * (double d) {
        return P(x * d, y * d);
    }
    double det(P p) {
        return add(x * p.y, - y * p.x);
    }
    double dot(P p) {
        return add(x * p.x, y * p.y);
    }
};
P p1, p2, pp1, pp2;
bool on_seg(P p1, P p2, P q) {
    return (p1 - q).det(p2 - q) == 0;
}
P intersection(P p1, P p2, P q1, P q2) {
    return p1 + (p2 - p1) * ((q2 - q1).det(q1 - p1) / (q2 - q1).det(p2 - p1));
}
int main() {
    int n, t, m;
    scanf("%d", &t);
    printf("INTERSECTING LINES OUTPUT\n");
    while (t--) {
        scanf("%lf%lf%lf%lf%lf%lf%lf%lf", &p1.x, &p1.y, &p2.x, &p2.y, &pp1.x, &pp1.y, &pp2. x, &pp2.y);
        if ((p1 - p2).det(pp1 - pp2) == 0) {
            if (on_seg(p1, p2, pp1) || on_seg(p1, p2, pp2)) printf("LINE\n");
            else printf("NONE\n");
        } else {
            P r = intersection(p1, p2, pp1, pp2);
            printf("POINT %.2lf %.2lf\n", r.x, r.y);
        }
    }
    printf("END OF OUTPUT\n");
    return 0;
}