Intersecting Lines
程序员文章站
2022-05-22 10:50:31
...
We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are
on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.
Input
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.
The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in
the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).
Output
There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect:
none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".
Sample Input
5 0 0 4 4 0 4 4 0 5 0 7 6 1 0 2 3 5 0 7 6 3 -6 4 -3 2 0 2 27 1 5 18 5 0 3 4 0 1 2 2 5Sample Output
INTERSECTING LINES OUTPUT POINT 2.00 2.00 NONE LINE POINT 2.00 5.00 POINT 1.07 2.20 END OF OUTPUT
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
//#include<bits/stdc++.h>
#define eps 1e-8
using namespace std;
int main()
{
int n;
double x1,y1,x2,y2,x3,y3,x4,y4;
scanf("%d",&n);
printf("INTERSECTING LINES OUTPUT\n");
for(int i=1;i<=n;i++)
{
scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3,&x4,&y4);
if((x4-x3)*(y2-y1)==(y4-y3)*(x2-x1))//斜率相同
{
if((x2-x1)*(y3-y1)==(y2-y1)*(x3-x1))
printf("LINE\n");
else
printf("NONE\n");
}
else
{
double a1=y1-y2,b1=x2-x1,c1=x1*y2-x2*y1;
double a2=y3-y4,b2=x4-x3,c2=x3*y4-x4*y3;
double x=(c2*b1-c1*b2)/(b2*a1-b1*a2);
double y=(a2*c1-a1*c2)/(b2*a1-b1*a2);
printf("POINT %.2f %.2f\n",x,y);
}
}
printf("END OF OUTPUT\n");
}
上一篇: codeforces906b(DFS)
下一篇: 2015-2016 Petrozavodsk Winter Training Camp, SPb SU + SPb AU Contest Greedy Game
推荐阅读
-
谷歌开源Land Lines:随便一笔匹配地球上最符合的地理或建筑物线条
-
Formatting Long Lines 格式化多行字符的shell脚本
-
【LeetCode】806. Number of Lines To Write String
-
3.1.1 Splitting Long Lines(拆分长行)
-
Parallel Lines
-
Parallel Lines(Aizu 1379)
-
Parallel Lines ICPC 2017 Japan Tsukuba
-
POJ·Intersecting Lines
-
UPC - 8839: Parallel Lines(DFS暴力)
-
pycharm shows "PEP:8 expected 2 blank lines ,found 1"