Intersecting Lines
Description We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. Input The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4). Output There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT". Sample Input
Sample Output
Source |
题意:给你四个点坐标两点一直线求这两直线状态相交就输出这点的交点
思路:求先求用y2-y1/(x2-x1)求出k,y=kx+b带入求,特判k=1和k=0情况如果x1=x2=x3=x4或y1=y2=y3=y4求
输出共线如果只有斜率相同输出相离其他带入公式x = (b1-b2)/(k2-k1) 和y=k1*((b1-b2)/(k2-k1))+b1解出
代码如下:
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
int n;double x1,x2,x3,y1,y2,y3,x4,y4;
scanf("%d",&n);
printf("INTERSECTING LINES OUTPUT\n");
for(int i=0;i<n;++i)
{
scanf("%lf %lf %lf %lf %lf %lf %lf %lf",&x1,&y1,&x2,&y2,&x3,&y3,&x4,&y4);
double k1 = (y2-y1)/(x2-x1);//求出线1斜率
if(x2 == x1)
{
k1 = 1;
}
if(y2 == y1)
{
k1 = 0;
}//特判两项
double k2 = (y4-y3)/(x4-x3);//求线2斜率
if(x4 == x3)
{
k2=1;
}
if(y4==y3){
k2 = 0;
}//特判两项
double b1 = (y1-k1*x1);
double b2 = (y3-k2*x3);//求出b1,b2;
if(x1 == x2 && x2 == x3 && x3 == x4)
{
printf("LINE\n");//x都相同输出line
}
else if(y1 == y2 && y2 == y3 && y3 == y4)
{
printf("LINE\n");//y都相同也输出line
}
else if(k1 == k2 && b1 == b2)
{
printf("LINE\n");//如果正常的话b相同也是
}
else if(k1 == k2)
{
printf("NONE\n");//只有k相同输出none
}
else
{
double s1 = (b1-b2)/(k2-k1);//求x坐标
if(x2 == x1)
{
s1 = x1;//特判斜率为1时
}
if(x4 == x3)
{
s1 = x3;//特判斜率为1时
}
double s2 = k1*((b1-b2)/(k2-k1))+b1;//求y坐标
printf("POINT %.2f %.2f\n",s1,s2);
}
}
printf("END OF OUTPUT\n");
return 0;
}
推荐阅读
-
谷歌开源Land Lines:随便一笔匹配地球上最符合的地理或建筑物线条
-
Formatting Long Lines 格式化多行字符的shell脚本
-
【LeetCode】806. Number of Lines To Write String
-
3.1.1 Splitting Long Lines(拆分长行)
-
Parallel Lines
-
Parallel Lines(Aizu 1379)
-
Parallel Lines ICPC 2017 Japan Tsukuba
-
POJ·Intersecting Lines
-
UPC - 8839: Parallel Lines(DFS暴力)
-
pycharm shows "PEP:8 expected 2 blank lines ,found 1"