欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

POJ 2318--TOYS(二分找点,叉积判断方向)

程序员文章站 2022-04-01 15:33:44
...

TOYS
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17974 Accepted: 8539
Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
POJ 2318--TOYS(二分找点,叉积判断方向)
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0
Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2
Hint

As the example illustrates, toys that fall on the boundary of the box are “in” the box.
Source

Rocky Mountain 2003

  • 题意:给n条边,划分成n+1个区域,再给定m个点坐标,点不会落在边界上和区域外,问每个区域中各自存在多少个点
  • 代码如下
#include<iostream>
#include<cstring> 
#include<string>
#include<algorithm> 
#include<vector> 
#include<stack> 
#include<bitset>
#include<cstdio> 
#include<cstdlib> 
#include<cmath> 
#include<set> 
#include<list> 
#include<deque> 
#include<map> 
#include<queue>
using namespace std;
const int MAX = 5005;

typedef struct point {
    int x;
    int y;
}point;
typedef struct value {
    point start;
    point end;
}v;
v edge[MAX];
int sum[MAX];
int n, m, x1, y11, x2, y2, flag = 1;
point tp;
int Xj, Yj;
int multi(point p1, point p2, point p0) {  //判断p1p0和p2p0的关系,<0,p1p0在p2p0的逆时针方向
    return (p1.x - p0.x)*(p2.y - p0.y) - (p2.x - p0.x)*(p1.y - p0.y);
}
void inset(point p) {
    int low = 0, high = n;
    while (low <= high) {
        int mid = (high + low) / 2;
        if (multi(p, edge[mid].start, edge[mid].end) < 0)    /*点p1在边的左侧*/
            high = mid - 1;
        else    //点p在边的右侧
            low = mid + 1;
    }
    if (multi(p, edge[low-1].start, edge[low-1].end) < 0 )
        sum[low-1]++;
    else
        sum[low]++;
}
int main() {
    while (~scanf("%d", &n) && n) {
        memset(sum, 0, sizeof(sum));
        if (flag == 1)flag++;
        else printf("\n");
        scanf("%d%d%d%d%d", &m, &x1, &y11, &x2, &y2);
        int Ui, Li;
        for (int i = 0; i < n; i++) {
            scanf("%d%d", &Ui, &Li);
            edge[i].start.x = Ui;
            edge[i].start.y = y11;
            edge[i].end.x = Li;
            edge[i].end.y = y2;
        }
        edge[n].start.x = x2;
        edge[n].start.y = y11;
        edge[n].end.x = x2;
        edge[n].end.y = y2;
        for (int j = 0; j < m; j++) {
            scanf("%d%d", &Xj, &Yj);
            tp.x = Xj;
            tp.y = Yj;
            inset(tp);
        }
        for (int i = 0; i <= n; i++)
            printf("%d: %d\n", i, sum[i]);
    }
    return 0;
}
  • Experience: 前面点的构造写成
  • -
1 edge[i].start = { Ui,y11 };
2 edge[i].end = { Li,y2 };
当发现这个错误的时候,我自己都被自己蠢哭了,Wa了2页,
一直以为是叉积方向搞错了,原来不是ORZ
这个是我真正意义上第一道计算几何,mark一下。
相关标签: POJ2318 叉积