欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

ccf 模拟题 24点问题

程序员文章站 2022-03-31 20:44:25
...

24点问题

题目
定义每一个游戏由 4 个从 1-9 的数字和 3 个四则运算符组成,保证四则运算符将数字两两隔开,不存在括号和其他字符,运算顺序按照四则运算顺序进行。其中加法用符号 + 表示,减法用符号 - 表示,乘法用小写字母 x 表示,除法用符号 / 表示。在游戏里除法为整除,例如 2 / 3 = 0,3 / 2 = 1, 4 / 2 = 2。
老师给了你 n 个游戏的解,请你编写程序验证每个游戏的结果是否为 24 。

输入
从标准输入读入数据。第一行输入一个整数 n,从第 2 行开始到第 n + 1 行中,每一行包含一个长度为 7的字符串,为上述的 24 点游戏,保证数据格式合法。

输出
输出到标准输出。
包含 n 行,对于每一个游戏,如果其结果为 24 则输出字符串 Yes,否则输出字符串 No。

输入样例
10
9+3+4x3
5+4x5x5
7-9-9+8
5x6/5x4
3+5+7+9
1x1+9-9
1x9-5/9
8/5+6x9
6x7-3x6
6x4+4/5

输出样例
Yes
No
No
Yes
Yes
No
No
No
Yes
Yes

样例解释
9+3+4 × 3 = 24
5+4 × 5 × 5 = 105
7 − 9 − 9+8= −3
5 × 6/5 × 4 = 24
3 + 5 + 7 + 9 = 24
1 × 1+9 − 9=1
1 × 9 − 5/9 = 9
8/5 + 6 × 9 = 55
6 × 7 − 3 × 6 = 24
6 × 4 + 4/5 = 24

解法:
用两个栈来模拟,一个栈来存数字,一个栈用来模拟运算符
数字和符号按顺序进栈
这个栈顶的符号是+的时候就把数字入数字栈
如果栈顶符号是-就把该数字变成负数放入数字栈
如果是除号或者乘号就该数字与当前栈顶做乘法或者除法再放入栈顶


import java.util.Scanner;
import java.util.Stack;

public class Main {
    public static void check(String str){
        Stack<Character> symbol = new Stack<>();
        Stack <Integer>number = new Stack<>();
        number.push(str.charAt(0)-'0');
        symbol.push(str.charAt(1));

        int index = 2;
        while(index < str.length()){
            if(str.charAt(index)-'0'<=9&&str.charAt(index)-'0'>=0){

                if(symbol.peek()=='x'){
                    int temp=number.pop();
                    number.push((str.charAt(index)-'0')*temp);
                    //number.pop();

                }
                if(symbol.peek()=='-'){
                    number.push((str.charAt(index)-'0')*-1);

                }
                 if(symbol.peek()=='/'){
                    int temp=number.pop();
                    number.push(temp/(str.charAt(index)-'0'));
                }
                 if(symbol.peek()=='+') {
                    number.push(str.charAt(index)-'0');
                }
            }
            if(str.charAt(index)=='x'||str.charAt(index)=='/'||str.charAt(index)=='+'||str.charAt(index)=='-'){
                symbol.push(str.charAt(index));
            }
            index++;
        }
        int sum = 0;
        Stack<Integer>stack3 = number;
        while(!number.isEmpty()){
            sum += number.peek();
            number.pop();
        }
        if( sum==24){
            System.out.println("Yes");
        }else{
            System.out.println("No");
        }
    }
    public static void main(String[] args) {
        Scanner sc =new Scanner(System.in);
        int n = sc.nextInt();
        for(int i = 1;i<=n;i++){

            String str = sc.next();
            check(str);

        }
    }
}