数据结构实验之查找三:树的种类统计
程序员文章站
2022-03-24 16:06:20
...
数据结构实验之查找三:树的种类统计
Time Limit: 400MS
Memory Limit: 65536KB
Problem Description
随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。
Input
输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。
Output
按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。
Example Input
2
This is an Appletree
this is an appletree
Example Output
this is an appletree 100.00%
/*
Name:数据结构实验之查找三:树的种类统计
Author:Mr.z
Time:2016-12-12
*/
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iomanip>
using namespace std;
struct BiTnode
{
char data[202];
int cnt;
BiTnode *lchild,*rchild;
};
int n;
BiTnode * CreatBitree(BiTnode * root,char *s){
if(!root){
root = new BiTnode;
root->lchild=NULL,root->rchild=NULL;
strcpy(root->data,s);
root->cnt=1;
}
else{
int cmp=strcmp(root->data,s);
if(cmp>0) root->lchild=CreatBitree(root->lchild,s);
else if(cmp<0) root->rchild=CreatBitree(root->rchild,s);
else root->cnt++;
}
return root;
}
void InOrder(BiTnode *root){
if(root){
InOrder(root->lchild);
printf("%s %.2lf%c\n",root->data,root->cnt*100.0/n,'%');
InOrder(root->rchild);
}
}
int main(){
char str[202];
BiTnode *root;
root = NULL;
scanf("%d\n",&n);
for(int i=0;i<n;i++){
gets(str);
for(int j=0;str[j];j++)
if(str[j]>='A' && str[j]<='Z')
str[j]+=32;
root=CreatBitree(root,str);
}
InOrder(root);
return 0;
}
/***************************************************
User name: zhxw150244李政
Result: Accepted
Take time: 0ms
Take Memory: 156KB
Submit time: 2016-12-15 11:27:16
****************************************************/
上一篇: 结构化数据,半结构化数据,非结构化数据非区别和示例
下一篇: js如何把html转换成图片格式