欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

数据结构实验之查找三:树的种类统计

程序员文章站 2022-03-24 16:04:32
...

数据结构实验之查找三:树的种类统计

Time Limit: 400 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。

Input

输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。

Output

按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。

Sample Input

2
This is an Appletree
this is an appletree

Sample Output

this is an appletree 100.00%
#include<bits/stdc++.h>

using namespace std;

int n;
struct bitree
{
    char data[25];
    int cnt;
    struct bitree *lc,*rc;
};
void create(bitree *&t,char s[])
{
    if(!t)
    {
        t = new bitree;
        strcpy(t->data,s);
        t->cnt = 1;
        t->rc = t->lc = NULL;
    }
    else
    {
        int k = strcmp(t->data,s);
        if(k>0)
            create(t->lc,s);
        else if (k<0)
            create(t->rc,s);
        else
            t->cnt++;
    }
}
void iorder(struct bitree *t)
{
    if(t)
    {
        iorder(t->lc);
        printf("%s %.2lf%c\n",t->data,t->cnt*100.0/n,'%');
        iorder(t->rc);
    }
}
int main()
{
    scanf("%d\n",&n);
    struct bitree *root=NULL;
    for(int i=0; i<n; i++)
    {
        char str[25];
        gets(str);
        for(int i=0; str[i]!='\0'; i++)
        {
            if(str[i]>='A'&&str[i]<='Z')
                str[i]+=32;
        }
        create(root,str);
    }
    iorder(root);
}