HDU 2586 How far away?
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
Input
First line is a single integer T(T<=10), indicating the number of test cases.
For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
Sample Input
2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1
Sample Output
10 25 100 100
dfs暴力求解
#include<bits/stdc++.h>
using namespace std;
int n, m;
int e;
int flag = 0;
struct node{
int to, cost;
};
vector<struct node>mp[40010];
int vis[40010];
void dfs(int s, int ans){
if(flag == 1)return;
if(vis[s])return;
if(s == e){
printf("%d\n", ans);
flag = 1;
return;
}
if(mp[s].empty())return;
int len = mp[s].size();
vis[s] = 1;
for(int i = 0; i <= len - 1; i++){
dfs(mp[s][i].to, ans + mp[s][i].cost);
}
vis[s] = 0;
}
int main(){
int t;
cin >> t;
int s;
while(t--){
cin >> n >> m;
for(int i = 1; i <= n - 1; i++){
int x, y, w;
cin >> x >> y >> w;
node t;
t.to = y;
t.cost = w;
mp[x].push_back(t);
t.to = x;
t.cost = w;
mp[y].push_back(t);
}
for(int i = 0; i <= m - 1; i++){
cin >> s >> e;
memset(vis, 0, sizeof(vis));
flag = 0;
dfs(s, 0);
}
for(int i = 0; i < n; i++){
mp[i].clear();
}
}
return 0;
}
上一篇: iOS求职之OC面试题