K - next_permutation(HDU 1027)
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, “I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too.” Ignatius says confidently, “OK, at last, I will save the Princess.”
“Now I will show you the first problem.” feng5166 says, “Given a sequence of number 1 to N, we define that 1,2,3…N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it’s easy to see the second smallest sequence is 1,2,3…N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It’s easy, isn’t is? Hahahahaha…”
Can you help Ignatius to solve this problem?
Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub’s demand. The input is terminated by the end of file.
Output
For each test case, you only have to output the sequence satisfied the BEelzebub’s demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
Sample Input
6 4
11 8
Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10
题解
题意:
- 给定正整数n,m,定义1,2,3,4,……,n-1,n为最小序列,n-1与n互换位置得到次小的序列。求dim小的序列。
思路:
- 这里用到algorithm里面的next_permutation()函数(全排列算法)。(这篇文章介绍得很详细)
Code
#include<iostream>
#include<algorithm>
using namespace std;
int *a;
int main()
{
int n, m;
while(cin >> n >> m)
{
a = new int[n];
for(int i=0;i<n;i++) a[i]=i+1;
while(--m) next_permutation(a,a+n);//字典序不断增大
for(int i = 0; i < n - 1; i++) printf("%d ", a[i]);
printf("%d\n",a[n - 1]);
delete [] a;//释放内存,new和delete一起使用
}
}
推荐阅读
-
hdu5289 Assignment(极差<k的子区间数量,单调性证明+双指针+单调队列)
-
HDU 5943 && 2016CCPC杭州 K: Kingdom of Obsession(二分匹配)
-
HDU6274&&2017CCPC杭州K Master of Sequence 【二分+预处理】
-
hdu5289 Assignment(极差<k的子区间数量,单调性证明+双指针+单调队列)
-
HDU 1027 打印沙漏
-
pku 1703,hdu 1027 、2062
-
HDU1027-Ignatius and the Princess II(全排列问题next_permutation函数的使用)
-
【HDU 1027】全排列 | 逆康托展开 | std::next_permutation | 栈 + 回溯搜索 | N
-
HDU 1027 Ignatius and the Princess II[DFS/全排列函数next_permutation]
-
HDU 1027 Ignatius and the Princess II(全排列)