欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU1027

程序员文章站 2022-03-22 13:27:15
...

Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?

Input

The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.

Output

For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

Sample Input

6 4
11 8

Sample Output

1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10

题目大意:给定一个长为N的字符串,规定1,2,3,...,N是最小序列,求第M小的序列

思路:可以发现,后面的 i 位数共有 i!种组合方式,所以判断M在哪个数的阶乘范围内,然后更改对应的序列

例如,题目所给的6 4,2!< 4 < 3!,所以要改变后面3位数,每移动一位数字有2!种组合(4开头有2!种组合,5开头也有2!种组合,6开头也有2!种组合,4开头的序列小于5开头的序列,5开头的序列小于6开头的序列),以此类推,直到确定最终的顺序

 

#include<cstdio>
#include<vector>
#include<set>
using namespace std;
int N, M;
int f[11];

int main()
{
    f[0] = 0; f[1] = 1;
    for (int i = 2; i < 11; i++)
        f[i] = f[i - 1] * i;

    while (scanf("%d %d", &N, &M) != EOF)
    {
        vector<int> A;
        int tmp = M;
        int L;  //还需改变位置的位数
        for (int i = 1; i <= 10; i++)
            if (tmp <= f[i])
            {
                L = i;
                break;
            }

        for (int i = 1; i <= N - L; i++)
            A.push_back(i);
        set<int> s;
        for (int i = N - L + 1; i <= N; i++)
            s.insert(i);

        for (int i = L; tmp != 0;)
        {
            if (tmp == f[i])
            {
                for (set<int>::reverse_iterator it = s.rbegin(); it != s.rend(); it++)
                {
                    A.push_back(*it);
                }
                s.clear();
                tmp = 0;
                break;
            }
            else if (tmp < f[i])
            {
                int t = tmp / f[i - 1];
                if (tmp % f[i - 1] == 0)
                {
                    set<int>::iterator it = s.begin();
                    for (int j = 1; j <= t - 1; j++)
                        it++;
                    A.push_back(*it);
                    s.erase(*it);
                    for (set<int>::reverse_iterator p = s.rbegin(); p != s.rend(); p++)
                        A.push_back(*p);
                    s.clear();
                    tmp = 0;
                    break;
                }
                else
                {
                    set<int>::iterator it = s.begin();
                    for (int j = 1; j <= t; j++)
                        it++;
                    A.push_back(*it);
                    s.erase(*it);
                    tmp = tmp - f[i - 1] * t;
                    i--;
                }
            }
        }

        for (set<int>::iterator it = s.begin(); it != s.end(); it++)
            A.push_back(*it);

        printf("%d", A[0]);
        for (int i = 1; i < A.size(); i++)
            printf(" %d", A[i]);
        printf("\n");
    }
    return 0;
}