set
set是一个不会包含重复元素的集合,是有序的。
定义方式 :set<数据类型>名称
基本操作:
例题:
Description
Small W is playing a summary game. Firstly, He takes N numbers. Secondly he takes out every pair of them and add this two numbers, thus he can get N*(N - 1)/2 new numbers. Thirdly he deletes the repeated number of the new numbers. Finally he gets the sum of the left numbers. Now small W want you to tell him what is the final sum.
Input
Multi test cases, every case occupies two lines, the first line contain n, then second line contain n numbers a 1, a 2, ……a n separated by exact one space. Process to the end of file.
[Technical Specification]
2 <= n <= 100
-1000000000 <= a i <= 1000000000
Output
For each case, output the final sum.
Sample Input
4
1 2 3 4
2
5 5
Sample Output
25
10
Hint
Firstly small W takes any pair of 1 2 3 4 and add them, he will get 3 4 5 5 6 7. Then he deletes the repeated numbers, he will get 3 4 5 6 7, Finally he gets the sum=3+4+5+6+7=25.
/*题意:输入n个数,输出两两求和得出的数再加和的值*/
#include<bits/stdc++.h>
using namespace std;
typedef long long ll; //数据过大,用long long
int main(){
int n;
ll num[105];
set<ll> s;
while(~scanf("%d",&n)){
s.clear();//每次给set集合清空,防止数据混乱。
for(int i=0;i<n;i++){
cin>>num[i];
}
for(int i=0;i<n;i++){
for(int j=i+1;j<n;j++){
s.insert(num[i]+num[j]);//set中的数据是不会重复的!
}
}
set<ll>::iterator it; //迭代器
ll sm=0; //必须再while循环内每次给sm赋0,避免多组数据输入会出现数据的混乱。
for(it=s.begin();it!=s.end();it++){
sm += *it; //*it 指针指向迭代器所代表的元素
}
cout<<sm<<endl;
}
return 0;
}
上一篇: hadoop(三)——hdfs(下)
下一篇: Set