欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

最长公共子序列问题

程序员文章站 2024-03-20 10:12:34
...

最长公共子序列问题

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

给定两个序列 X={x1,x2,…,xm} 和 Y={y1,y2,…,yn},找出X和Y的最长公共子序列。

Input

输入数据有多组,每组有两行 ,每行为一个长度不超过500的字符串(输入全是大写英文字母(A,Z)),表示序列X和Y。

Output

每组输出一行,表示所求得的最长公共子序列的长度,若不存在公共子序列,则输出0。

Sample Input

ABCBDAB
BDCABA

Sample Output

4

代码如下:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>


int main()
{
    char X[500],Y[510];
    int c[510][510]= {0,};
    while(scanf("%s%s",X,Y)!=EOF)
    {
        int i,j,x,y;
        x=strlen(X);
        y=strlen(Y);
        for(i=0; i<=x; i++)
        {
            c[i][0]=0;
        }
        for(j=0; j<=y; j++)
        {
            c[0][j]=0;
        }
        for(i=1; i<=x; i++)
        {
            for(j=1; j<=y; j++)
            {
                if(X[i-1]==Y[j-1])
                {
                    c[i][j]=c[i-1][j-1]+1;
                }
                else
                {
                    if(c[i-1][j]>c[i][j-1])
                    {
                        c[i][j]=c[i-1][j];
                    }
                    else c[i][j]=c[i][j-1];

                }

            }

        }
        printf("%d\n",c[x][y]);

    }

    return 0;
}