欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU3342 Legal or Not (拓扑排序)

程序员文章站 2024-03-19 12:04:10
...

Legal or Not

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many “holy cows” like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost “master”, and Lost will have a nice “prentice”. By and by, there are many pairs of “master and prentice”. But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it’s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian’s master and, at the same time, 3xian is HH’s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the “master and prentice” relation is transitive. It means that if A is B’s master ans B is C’s master, then A is C’s master.
Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y’s master and y is x’s prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,…, N-1). We use their numbers instead of their names.
Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output “YES”, otherwise “NO”.
Sample Input
3 2
0 1
1 2
2 2
0 1
1 0
0 0
Sample Output
YES
NO

当存在剩余所有点的入度都不为0时,即为不合法。
ac代码:

#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>

using namespace std;
int in[600];
vector <int> ve[600];

int main(){
	int n,m;
	while(cin>>n>>m&&(n||m)){
		for(int i=0;i<n;i++){
		ve[i].clear();
		in[i]=0;
		}
		int a,b;
		for(int i=0;i<m;i++){
			cin>>a>>b;
			ve[a].push_back(b);
			in[b]++;
	
 	}
		
	priority_queue<int,vector<int>,greater<int> > que;
	for(int i=0;i<n;i++){
		if(in[i]==0){
			que.push(i);
		} 
	}
	int flag=0;
	while(!que.empty()){
		int xx=que.top();
		que.pop();
		
			flag++;//cout<<xx<<" "<<flag<<endl;
		for(int i=0;i<ve[xx].size();i++){
			in[ve[xx][i]]--;
			if(in[ve[xx][i]]==0){
				//cout<<ve[xx][i]<<endl;
				que.push(ve[xx][i]);
			}
		}
	}
	if(flag==n) cout<<"YES"<<endl;
	else cout<<"NO"<<endl;
	}
	
	return 0;
}

/*
3 3
0 1
1 2
0 2
3 2
2 0
0 2
0 0
*/

上一篇: RSA算法(-)

下一篇: 获取 RSA key