PAT (Basic Level) Practice 1038 统计同成绩学生
程序员文章站
2024-03-18 23:03:58
...
1038 统计同成绩学生 (20分)
本题要求读入 N 名学生的成绩,将获得某一给定分数的学生人数输出。
输入格式:
输入在第 1 行给出不超过 105 的正整数 N,即学生总人数。随后一行给出 N 名学生的百分制整数成绩,中间以空格分隔。最后一行给出要查询的分数个数 K(不超过 N 的正整数),随后是 K 个分数,中间以空格分隔。
输出格式:
在一行中按查询顺序给出得分等于指定分数的学生人数,中间以空格分隔,但行末不得有多余空格。
输入样例:
10
60 75 90 55 75 99 82 90 75 50
3 75 90 88
输出样例:
3 2 0
#include<iostream>
#include<vector>
using namespace std;
int main(){
int n,m,temp;
vector<int>b(101);
cin>>n;
for(int i=0;i<n;i++){
cin>>temp;
b[temp]++;
}
cin>>m;
for(int i=0;i<m;i++){
cin>>temp;
if(i!=0) cout<<" ";
cout<<b[temp];
}
return 0;
}
推荐阅读
-
PAT (Basic Level) Practice (中文)--1038 统计同成绩学生 (20 分)
-
PAT (Basic Level) Practice 1038 统计同成绩学生
-
PAT (Basic Level) Practice (中文)1038 统计同成绩学生 (20 分)
-
PATB 1038. 统计同成绩学生(20)
-
PAT (Basic Level) Practice 1021 个位数统计
-
PAT (Basic Level) Practice 1004 成绩排名
-
PATB 1038. 统计同成绩学生(20)
-
PAT (Basic Level) Practice (中文)1004 成绩排名 (20分) (结构体排序)
-
PAT (Basic Level) Practice (中文)1038 统计同成绩学生
-
PAT (Basic Level) Practice 1004 成绩排名