欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

3258 POJ River Hopscotch(二分)

程序员文章站 2024-03-17 15:30:34
...

River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 24389 Accepted: 10087
Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance before he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2…N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks
Sample Input

25 5 2
2
14
11
21
17
Sample Output

4
Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题目链接:http://poj.org/problem?id=3258
solution:二分、每次判断mid最小空间的在最大值需要移走多少石头

#include <iostream>
#include <algorithm>
using namespace std;

int a[50005], l, m, n;
int rec(int l, int r){
	int mid;
	while (l <= r){
		mid = (l + r) / 2;
		int cnt = 0, last = 0;
		for (int i = 1; i <= n + 1; ++i){
			if (mid >= a[i] - a[last])++cnt;
			else last = i;
		}
		if (cnt > m)r = mid - 1;
		else l = mid + 1;
	}
	return l;
}

int main()
{
	scanf("%d%d%d", &l, &n, &m);
	a[0] = 0;
	a[n + 1] = l;
	for (int i = 1; i <= n; ++i)scanf("%d", &a[i]);
	sort(a, a + n + 1);
	printf("%d\n", rec(0, l));
	return 0;
}

上一篇: 分蛋糕

下一篇: CodeForces 1010A