欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

POJ 3258 River Hopscotch(二分)

程序员文章站 2024-03-17 15:26:34
...

题目来源:http://poj.org/problem?id=3258

问题描述

River Hopscotch

Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 20319

 

Accepted: 8457

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M 
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

Source

USACO 2006 December Silver

------------------------------------------------------------

题意

河中有N+2块石头,0处是起始石头,L处是终止石头。现在可以拿走除起始石头和终止石头外N块石头中的M块石头,求各种拿走M块石头的方式中,使得各石头间最小间距的最大值的方式,输出这种方式下,拿走M块石头后石头最小间距的值

------------------------------------------------------------

思路

结果的上界是L/(N-M+1),下界是拿走M块石头之前的最小间距。二分查找结果,对于每一个结果,检查是否可行。注意二分的写法,很容易出错。

检查可行的时候思路也比较巧妙,不是统计需要拿走的石块数量,而是当石头可以拿走的条件下大于等于给定间距值的间距数量。

------------------------------------------------------------

代码

#include<cstdio>
#include<algorithm>

const int INF = 0x3f3f3f3f;
int a[50005];
int L, N, M;

bool check(int x){
	int st=0,ed=st+1,sum=0;
	for(;ed<=N+1;ed++){//遍历所有区间 
		if((a[ed]-a[st])>=x){//如果这个区间长度符合要求 
			st=ed;//开始检测后面的区间 
			sum++;//记下这个区间 
		}
	}
	if(sum>=(2+N-M-1)) return true;//若区间数>=去掉M块石头后的区间数则x可行 
	else return false;
}

int main()
{
#ifndef ONLINE_JUDGE
	freopen("3258.txt", "r", stdin);
#endif
	int i, left, right, mid, minl = 0, ans;
	while (scanf("%d%d%d", &L, &N, &M) != EOF)
	{
		right = L/(N-M+1);
		a[0] = 0;
		for (i=1; i<=N; i++)
		{
			scanf("%d", &a[i]);
			
		}
		a[N+1] = L;
		std::sort(a+1, a+N+1);
		for (i=1; i<=N; i++)
		{
			if (i==0)
			{
				minl = std::min(minl, a[i]);
			}
			else
			{
				minl = std::min(minl, a[i]-a[i-1]);
			}
		}
		left = minl;
		while (left <= right)
		{
			mid = (left+right)/2;
			if (!check(mid))
			{
				right = mid - 1;
			}
			else
			{
				left = mid + 1;
				ans = mid;
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}

 

相关标签: poj Cpp 二分