欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU - 2199 Can you solve this equation? (二分)

程序员文章站 2024-03-17 15:21:58
...

Can you solve this equation?

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input
2
100
-4

Sample Output
1.6152
No solution!

题目大意:给定一个递增函数,问函数在0,100的闭区间上是否有与给定数字相等的函数值,若有则输出自变量的值。浮点数的二分

#include <iostream>
#include <cmath>
#include <algorithm>
#include <cstdio>

using namespace std;

double f(double x)
{
    double ans = 8*pow(x, 4) + 7*pow(x, 3) + 2*pow(x, 2) + 3*x + 6;
    return ans;
}

int main()
{
    int t;
    double y, lo, hi, mid;
    cin >> t;
    while(t--)
    {
        cin >> y;
        if(y>=6 && y<=f(100))
        {
            lo = 0;
            hi = 100;
            while(hi-lo>1e-8)//设置精度,防止死循环
            {
                mid = (hi+lo)/2.0;
                if(f(mid)>y)
                    hi = mid;//浮点数的二分不需要移动
                else
                    lo = mid;
            }
            printf("%.4lf\n", lo);
        }
        else
            cout << "No solution!" << endl;
    }
    return 0;
}