Can you solve this equation? (HDU-2199)二分查找
程序员文章站
2022-03-13 22:45:44
...
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2 100 -4
Sample Output
1.6152 No solution!
题意:给你方程和y,让你求在0-100中有没有解。
思路:典型的二分查找,设l=0,r=100,套用二分模板,注意精度,这道题就ok了。
AC代码:
#include <bits/stdc++.h>
typedef long long ll;
const int maxx=1010;
const int inf=0x3f3f3f3f;
using namespace std;
double f(double x)
{
return 8*pow(x,4.0)+7*pow(x,3.0)+2*pow(x,2.0)+3*x+6;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
double y;
double l,r,mid;
scanf("%lf",&y);
l=0;
r=100;
if(f(l)<=y && y<=f(r))
{
while(r-l>1e-6)
{
mid=(l+r)/2;
double ans=f(mid);
if(ans>y)
{
r=mid-1e-7;
}
else
l=mid+1e-7;
}
printf("%.4lf\n",mid);
}
else
printf("No solution!\n");
}
return 0;
}