1253: The 3n + 1 problem
题目
Description
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.
Consider the following algorithm:
input n
print n
if n = 1 then STOP
if n is odd then n <- 3n + 1
else n <- n / 2
GOTO 2
Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1
It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)
Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.
For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.
Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.
You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.
You can assume that no opperation overflows a 32-bit integer.
Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).
Sample Input
1 10
100 200
201 210
900 1000
Sample Output
1 10 20
100 200 125
201 210 89
900 1000 174
代码块
题目的大致意思,是找区间中转化次数最多一个,并输出转化次数
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner cn = new Scanner(System.in);
while (cn.hasNext()) {
int a = cn.nextInt();
int b = cn.nextInt();
int max = 0;
System.out.print(a+" "+b+" ");
for (int i = a; i <= b; i++) {
int n = i, sum = 1;
while (n !=1) {
if (n % 2 != 0)
n = 3 * n + 1;
else
n = n / 2;
sum++;
}
if (max < sum)
max = sum;
}
System.out.println(max);
}
}
}
上一篇: 1272: 三位数反转
推荐阅读
-
1253: The 3n + 1 problem
-
php n+1 problem and laravel预加载(orderBy排序)
-
设计一个算法:用不多于3n/2的平均比较次数,在数组A[1,...,n]中找出最大值和最小值的元素
-
[Algorithm] 1. A+B Problem
-
解决:[ERROR] Error executing Maven. [ERROR] 1 problem was encountered while building the effective set
-
[ERROR] Error executing Maven. [ERROR] 1 problem was encountered while building the effective set
-
【线段树】【模板】讲解 + 例题1 HDU - 1754 I Hate It (点修改分数)+ 例题二 POJ - 3468 A Simple Problem with Integers(区间加值)
-
[Algorithm] 1. A+B Problem