欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

1272: 三位数反转

程序员文章站 2024-03-16 15:56:34
...

题目

Description

输入一个三位数,求他翻转后的三位数
Input

一个三位数

Output

翻转后的三位数,要求忽略前导0

Sample Input

120
Sample Output

21
HINT

题目要求忽略前导0,

代码块


import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner cn = new Scanner(System.in);
        int a = cn.nextInt();
        System.out.println(back(a));
    }

    private static int back(int a) {
        int s = 0;
        while(a>0){
            s = s*10 + a%10;
            a/=10;
        }
        return s;
    }
}