欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

1254: n-1位数

程序员文章站 2024-03-16 15:56:46
...

题目

Description

已知w是一个大于10但不大于1000000的无符号整数,若w是n(n ≥ 2)位的整数,则求出w的后n-1位的数。

Input

第一行为M,表示测试数据组数。
接下来M行,每行包含一个测试数据。

Output

输出M行,每行为对应行的n-1位数(忽略前缀0)。如果除了最高位外,其余位都为0,则输出0。

Sample Input

4
1023
5923
923
1000
Sample Output

23
923
23
0

代码块


import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner cn = new Scanner(System.in);
        int t= cn.nextInt();
        while(t-->0){
            int n = cn.nextInt();
            int z = n,count =0;
            while(z>0){
                z/=10;
                count++;
            }
            int m = (int) Math.pow(10, count-1);
            int ans = n%m;
            System.out.println(ans);
        }
    }
}