find your present (2)
In the new year party, everybody will get a “special present”.Now it’s
your turn to get your special present, a lot of presents now putting
on the desk, and only one of them will be yours.Each present has a
card number on it, and your present’s card number will be the one that
different from all the others, and you can assume that only one number
appear odd times.For example, there are 5 present, and their card
numbers are 1, 2, 3, 2, 1.so your present will be the one with the
card number of 3, because 3 is the number that different from all the
others.
Input
The input file will consist of several cases. Each case will be
presented by an integer n (1<=n<1000000, and n is odd) at first.
Following that, n positive integers will be given in a line, all
integers will smaller than 2^31. These numbers indicate the card
numbers of the presents.n = 0 ends the input.
Output
For each case, output an integer in a line, which is the card number
of your present.
Sample Input
5
1 1 3 2 2
3
1 2 1
0
Sample Output
3
2
hint
use scanf to avoid Time Limit Exceeded
代码1:
一开始做的时候,我开辟了一个数组来记录每个数出现的次数(也就是桶),但题干上说 输入的数smaller than 2^31,显然使用数组来存储次数容易越界。改进了一下,先对数进行排序,再遍历每个出现的次数。
#include<stdio.h>
#include<algorithm>
using namespace std;
int num[1000001];
int main()
{
int i,t;
while(~scanf("%d",&t))
{
int flag=0;
if(t==0)
break;
for(i=0;i<t;i++)
{
scanf("%d",&num[i]);
}
sort(num,num+t);
int cnt=1;
for(i=0;i<t-1;i++)
{
if(num[i]==num[i+1])
{
cnt++;
}else{
if(cnt%2==1)
{
printf("%d\n",num[i]);
flag=1;
break;
}else
cnt=1;
}
}
if(cnt%2==1&&!flag)
printf("%d\n",num[i]);
}
return 0;
}
以下的两个代码是参考的大神的博客,没得说,代码简洁,算法简单。
代码2:
为了节约内存,可以用STL里面的set,map等容器。
当容器里没有这个元素的时候,就插入这个元素,否则,删除这个元素。
最后,容器中肯定只剩下一个元素,便是我们所要的结果。
#include <set>
#include <stdio.h>
using namespace std;
int main()
{
int n,x;
set <int> S;
while(scanf("%d",&n),n)
{
while(n--)
{
scanf("%d",&x);
if(S.find(x) == S.end()) //没找到,插入
S.insert(x);
else //找到了,删除
S.erase(x);
}
printf("%d\n",*S.begin());
S.clear();
}
return 0;
}
代码3:
其实,这题还有个更好的方法————位异或。
我们先了解一下位异或的运算法则吧:
1、a^b = b^a。
2、(a^b)^c = a^(b^c)。
3、a^b^a = b。
对于一个任意一个数n,它有几个特殊的性质:
1、0^n = n。
2、n^n = 0。
所以可以通过每次异或运算,最后剩下的值就是出现奇数次的那个数字。
#include <stdio.h>
int main()
{
int n,x,ans;
while(scanf("%d",&n),n)
{
ans = 0;
while(n--)
{
scanf("%d",&x);
ans ^= x;
}
printf("%d\n",ans);
}
return 0;
}
PS:话说通过位运算的这些性质,可以通过不借用中间变量实现a,b的值的交换。
void swap(int &a,int &b)
{
a ^= b;
b ^= a;
a ^= b;
}
上一篇: 计算0到n(包括n)之间2的个数
下一篇: 计算1-n之间1的个数
推荐阅读
-
find your present (2)
-
Yale CAS异常问题总结(2)Unable to validate ProxyTicketValidator之unable to find valid certification path to requested target 博客分类: Security异常问题 JavaSUN.netSecurityApache
-
Given n coins and a pan balance,find the only counterfeit 2 博客分类: algorithms RESTGo
-
Codeforces Beta Round #4 (Div. 2 Only) D. Mysterious Present_html/css_WEB-ITnose
-
Find X2系列DXO拿第一!OPPO:坚持自己影像理念和对好效果追求
-
libxml2 configure: error: xml2-config not found. Please check your libxml2 installation.
-
OPPO沈义人曝Find X2标准版:影像区隔、整机轻盈、专属配色
-
OPPO副总沈义人:Find X2 Pro太耀眼了 所有旗舰中数一数二
-
MWC展会取消 OPPO Find X2发布会延期
-
libxml2 configure: error: xml2-config not found. Please check your libxml2 installation.