欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Robot

程序员文章站 2024-03-15 14:05:59
...

Michael has a telecontrol robot. One day he put the robot on a loop with n cells. The cells are numbered from 1 to n clockwise.

Robot


At first the robot is in cell 1. Then Michael uses a remote control to send m commands to the robot. A command will make the robot walk some distance. Unfortunately the direction part on the remote control is broken, so for every command the robot will chose a direction(clockwise or anticlockwise) randomly with equal possibility, and then walk w cells forward.
Michael wants to know the possibility of the robot stopping in the cell that cell number >= l and <= r after m commands.
Input 
There are multiple test cases.
Each test case contains several lines.
The first line contains four integers: above mentioned n(1≤n≤200) ,m(0≤m≤1,000,000),l,r(1≤l≤r≤n).
Then m lines follow, each representing a command. A command is a integer w(1≤w≤100) representing the cell length the robot will walk for this command.  
The input end with n=0,m=0,l=0,r=0. You should not process this test case.
Output 
For each test case in the input, you should output a line with the expected possibility. Output should be round to 4 digits after decimal points. Sample Input
3 1 1 2
1
5 2 4 4
1
2
0 0 0 0
Sample Output
0.5000
0.2500
暴力能过.......

最多200个位置,而机器人可能存在的位置是以2的指数倍增长的,如果模拟这个过程的话,首先得合并由不同位置到同一位置的可能性,其次内存可能不够,最后我就是想偷懒才想暴力的.......
解体思路:

从0到n-1(容易取模)顺序扫一遍,当发现该位置概率不为0时,将其概率除2更新到另外一组数组中
两组数组轮流更新(节省空间)直到m为0

Robot

#include<cstdio>
using namespace std;
int main()
{
	int n,m,l,r;
	while(scanf("%d%d%d%d",&n,&m,&l,&r),n)
	{
		double an[2][205]={0},sum=0;
		int num=0;
		an[0][0]=1;
		while(m--)
		{
			int cells;
			num++;
			scanf("%d",&cells);
			for(int i=0;i<n;i++)
			{
				if(an[(num+1)&1][i])
				{
					an[num&1][(i+n-cells)%n]+=an[(num+1)&1][i]/2;
					an[num&1][(i+n+cells)%n]+=an[(num+1)&1][i]/2;
					an[(num+1)&1][i]=0.0;
				}
			}	
		}
		for(int i=l-1;i<r;i++)
		{
			sum+=an[(num)&1][i];
		}
		printf("%.4f\n",sum);
	}
	return 0;
}