欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU - 1317 XYZZY

程序员文章站 2024-02-24 22:42:58
...

XYZZY

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6667    Accepted Submission(s): 1928

Problem Description
It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable.
Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms.

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time.
 

Input
The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing:

the energy value for room i
the number of doorways leaving room i
a list of the rooms that are reachable by the doorways leaving room i
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case.

Output
In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless".
 
Sample Input

50 1 2-60 1 3-60 1 420 1 50 050 1 220 1 3-60 1 4-60 1 50 050 1 221 1 3-60 1 4-60 1 50 050 1 220 2 1 3-60 1 4-60 1 50 0-1
Sample Output

hopelesshopelesswinnablewinnable

边没有权,点有权,所以另外用一个数组存点的权值。然后还要判断正权回路,判断正权回路之后还要判断一下这条回路能不能到达终点。

#include <iostream>
#include <stdio.h>
#include <string.h>
#define inf 0x3f3f3f3f
using namespace std;
struct node{
	int a,b;
}edge[110*110];
int en[110];//点的权值
int dis[110];//最短路径
int w[110][110];//点的连通性
void Ford (int m,int n)
{
    int i,j;
    for (int i = 1;i <= m; i++){
		dis[i] = -inf;
		w[i][i] = 1;
    }
    dis[1] = 100;

    for (i = 1;i <= m-1;i++){
        for (j = 1;j <= n;j++){
            if (dis[edge[j].b] < dis[edge[j].a]+en[edge[j].b] && dis[edge[j].a]+en[edge[j].b] > 0){//为了防止走到半路突然
            	//能量值为负,所以松弛的时候新的边必须满足权值为正。
                dis[edge[j].b] = dis[edge[j].a]+en[edge[j].b];
            }
        }
    }
    for (int i = 1;i <= m; i++){//判断连通性
		for (int j = 1;j <= m; j++){
			for (int k = 1;k <= m; k++){
				w[j][k] = w[j][k] || (w[j][i] && w[i][k]);
			}
		}
    }
	for (j = 1;j <= n;j++){//判断正权回路
		if (dis[edge[j].b] < dis[edge[j].a]+en[edge[j].b] && dis[edge[j].a]+en[edge[j].b] > 0){
			if (w[edge[j].b][m]){//=如果回路中的点可以到达m点
				cout <<"winnable\n";
				return ;
			}
		}
	}
	if (dis[m] > 0){
		cout << "winnable\n";
	}
	else{
		cout << "hopeless\n";
	}
}
int main ()
{
	int m;
	while (~scanf ("%d",&m) && m != -1){
		int cut = 1;
		memset(en,0,sizeof en);
		memset(edge,0,sizeof edge);
		memset(w,0,sizeof w);
		for (int k = 1;k <= m; k++){
			int total;
			cin >> en[k] >> total;
			for (int i = 1;i <= total; i++){
				int por;
				cin >> por;
				w[k][por] = 1;
				edge[cut].a = k;
				edge[cut++].b = por;
			}
		}
		Ford (m,cut-1);
	}

	return 0;
}