欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU - 1004 Let the Balloon Rise (map)

程序员文章站 2024-02-15 17:54:58
...

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1004点击打开链接


Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 124355    Accepted Submission(s): 49067


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input

5 green red blue red red 3 pink orange pink 0
 

Sample Output

red pink
 

Author
WU, Jiazhi
 

Source
 

Recommend
JGShining
 
map简单应用


#include <iostream>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <stack>
#include <limits>
#include <string>
#include <string.h>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <math.h>
using namespace std;
map<string ,int > ::iterator it;
int main()
{
  map<string ,int > mmap;
  int n=0;
  while(~scanf("%d",&n)&&n)
  {
      mmap.clear();
      while(n--)
      {
          string s;
          cin >> s;
          mmap[s]++;
      }
      int sum=0;
      string ans;
      for(it=mmap.begin();it!=mmap.end();it++)
      {
          if((*it).second>sum)
            {
                sum=(*it).second;
                ans=(*it).first;
            }
      }
    cout << ans << endl;
  }
}