欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Let the Balloon Rise HDU - 1004(map)

程序员文章站 2022-03-10 20:29:50
...

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink

输入n种颜色,输出出现次数最多的那个颜色,stl回顾,map

map<string,float>m;
m[“Jake”]=98.5;
m[“Bob”]=95.5;
map<string,float>::iterator it;
*
for(it=m.begin();it!=m.end();it++)
//例"Jake"=(*it).first;98.5=(*it).second;
*
m.erase(“Bob”);//删除元素
m.find(“Bob”);//查找元素
m.clear()//清空m;

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<cmath>
#include<algorithm>
#include<map>
using namespace std;
int n;
map<string,int>m;
map<string,int>::iterator it;
int main()
{
    while(cin>>n)
    {
        string a,b;
        if(n==0)
            break;
        int flag=0;
        for(int i=0;i<n;i++)
        {
            cin>>a;
            m[a]++;
        }
        for(it=m.begin();it!=m.end();it++)
        {
            if((*it).second>flag)
            {
                flag=(*it).second;
                b=(*it).first;
            }
        }
        cout<<b<<endl;
        m.clear();
    }
}

相关标签: map