欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

【扩欧】同余方程

程序员文章站 2024-02-11 16:44:28
...

【扩欧】同余方程

SampleSample InputInput
3 10
SampleSample OutputOutput
7

TrainTrain ofof ThoughtThought

扩展欧几里得
(第一个题解的解释个人觉得比较好)

#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#define ll long long
using namespace std;
ll x, y;
void init(ll a, ll b)
{
	if(b == 0)
	{
		x = 1;
		y = 0;
		return;
	}
	init(b, a % b);
	ll c = x;
	x = y;
	y = c - a / b * y;
	return;
}
int main()
{
	ll a, b;
	scanf("%lld%lld", &a, &b);
	init(a, b);
	x = (x + b) % b;
	printf("%lld", x);
}

上一篇: UVA - 12169 Disgruntled Judge

下一篇: