你好,容斥原理---层叠消融
Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
Output
For each case, output the number.
Sample Input
12 2 2 3Sample Output
7
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
#include<cmath>
#include<string>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
//层叠消融---偶消奇不消
ll num[11];
ll m,n;
ll sum=0,cnt;
ll gcd(ll a,ll b){
return b==0?a:gcd(b,a%b);
}
ll LCM(ll a,ll b){
return a/gcd(a,b)*b;
}
void dfs(int i,ll lcm,ll step){
if(step&1)//如果是层叠奇数次
sum+=(n-1)/lcm;
else sum-=(n-1)/lcm;//否则消去
for(int k=i+1;k<cnt;k++){
dfs(k,LCM(lcm,num[k]),step+1);
}
}
int main(){
ll x;
while(cin>>n>>m){
cnt=1;
for(int i=1;i<=m;i++){
cin>>x;
if(x>0&&x<n)num[cnt++]=x;
}
sum=0;
for(int i=1;i<cnt;i++){
dfs(i,num[i],1);
}
cout<<sum<<endl;
}
return 0;
}
上一篇: C#.net中的类型转换详细介绍
下一篇: jzoj 5835. Prime
推荐阅读
-
算法题解之容斥原理
-
n以内与n互素的平方和(算数基本定理+容斥原理)
-
HDU 6425(容斥原理)
-
lightOJ 1161 Extreme GCD(素数四元组)[容斥原理]
-
你好,容斥原理---层叠消融
-
cf559C. Gerald and Giant Chess(容斥原理)
-
2018蓝桥杯模拟赛(一)I【容斥原理】
-
Codeforces Round #258 (Div. 2)Devu and Flowers 容斥原理_html/css_WEB-ITnose
-
cf449D. Jzzhu and Numbers(容斥原理 高维前缀和)
-
BZOJ2005: [Noi2010]能量采集(容斥原理 莫比乌斯反演)