三个数的和为0
程序员文章站
2024-02-02 18:31:40
...
三个数的和为0
给出一个长度为N的无序数组,数组中的元素为整数,有正有负包括0,并互不相等。从中找出所有和 = 0的3个数的组合。如果没有这样的组合,输出No Solution。如果有多个,按照3个数中最小的数从小到大排序,如果最小的数相等则按照第二小的数排序。
Input
第1行,1个数N,N为数组的长度(0 <= N <= 1000)
第2 - N + 1行:Aii(-10^9 <= Aii <= 10^9)
Output
如果没有符合条件的组合,输出No Solution。
如果有多个,按照3个数中最小的数从小到大排序,如果最小的数相等则继续按照第二小的数排序。每行3个数,中间用空格分隔,并且这3个数按照从小到大的顺序排列。
Sample Input
7
-3
-2
-1
0
1
2
3
Sample Output
-3 0 3
-3 1 2
-2 -1 3
-2 0 2
-1 0 1
分析:
3个for循环可以解决
代码总览:
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
int n,a[10000],i,j,k;
while(scanf("%d",&n)!=EOF)
{
int count=0;
for(i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n);
for(i=0;i<n;i++)
for(j=i+1;j<n;j++)
for(k=j+1;k<n;k++)
if(a[i]+a[j]+a[k]==0)
{
count++;
printf("%d %d %d\n",a[i],a[j],a[k]);
}
if(count==0)
printf("No Solution\n");
}
return 0;
}