codevs1116 四色问题
程序员文章站
2024-01-13 19:56:04
...
给定N(小于等于8)个点的地图,以及地图上各点的相邻关系,请输出用4种颜色将地图涂色的所有方案数(要求相邻两点不能涂成相同的颜色)
数据中0代表不相邻,1代表相邻
输入描述 Input Description
第一行一个整数n,代表地图上有n个点
接下来n行,每行n个整数,每个整数是0或者1。第i行第j列的值代表了第i个点和第j个点之间是相邻的还是不相邻,相邻就是1,不相邻就是0.
我们保证a[i][j] = a[j][i] (a[i,j] = a[j,i])
输出描述 Output Description
染色的方案数
样例输入 Sample Input
8
0 0 0 1 0 0 1 0
0 0 0 0 0 1 0 1
0 0 0 0 0 0 1 0
1 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0
0 1 0 0 0 0 0 0
1 0 1 0 0 0 0 0
0 1 0 0 0 0 0 0
样例输出 Sample Output
15552
数据范围及提示 Data Size & Hint
n<=8
#include <iostream>
#include<algorithm>
#include <memory.h>
using namespace std;
int n;
int graph[8][8];//存临接矩阵
int color[8];//存每个点的染色情况
int counter = 0;
void A(int x)
{
if (x==n)
{
counter++;
return;
}
int i, j;
for (i=1;i<=4;i++)//遍历4种颜色
{
for (j=0;j<n;j++)//遍历和其相邻的点
if (graph[x][j]==1&&color[j]==i)//如果相邻且颜色一样则跳出
break;
if (j==n)
{//如果没有跳出,则代表当前选择的颜色是可以使用的
color[x] = i;
A(x + 1);
color[x] = -1;
}
}
}
int main()
{
cin >> n;
for (int i=0;i<n;i++)
for (int j=0;j<n;j++)
cin >> graph[i][j];
A(0);
cout << counter;
cin >> n;
return 0;
}