欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

【codevs 1116】四色问题

程序员文章站 2022-05-20 23:13:40
...

题目描述 Description
给定N(小于等于8)个点的地图,以及地图上各点的相邻关系,请输出用4种颜色将地图涂色的所有方案数(要求相邻两点不能涂成相同的颜色)

数据中0代表不相邻,1代表相邻

输入描述 Input Description
第一行一个整数n,代表地图上有n个点

接下来n行,每行n个整数,每个整数是0或者1。第i行第j列的值代表了第i个点和第j个点之间是相邻的还是不相邻,相邻就是1,不相邻就是0.

我们保证a[i][j] = a[j][i] (a[i,j] = a[j,i])

输出描述 Output Description
染色的方案数

样例输入 Sample Input
8
0 0 0 1 0 0 1 0
0 0 0 0 0 1 0 1
0 0 0 0 0 0 1 0
1 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0
0 1 0 0 0 0 0 0
1 0 1 0 0 0 0 0
0 1 0 0 0 0 0 0

样例输出 Sample Output
15552

数据范围及提示 Data Size & Hint
n<=8

调不出来,搜题解了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1000+1;
bool a[maxn][maxn];
int c[maxn];
bool pd=0;
int n,ans;
int dfs(int k)
{
    if(k==n+1) ans++;
    else for(int i=1;i<=4;i++)
    {
        for(int j=1;j<=n;j++)
        if(c[j]==i&&a[k][j])
        {
            pd=1;//k号点不能再涂第i种颜色 
            //break;
        }
        if(pd==0)
        {
            c[k]=i;
            dfs(k+1);
        }
        pd=0;
    }
    c[k]=0;
    return ans;
}
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    for(int j=1;j<=n;j++)
    scanf("%d",&a[i][j]);
    cout<<dfs(1)<<'\n';
    return 0;
}