欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

POJ-1328 Radar Installation(贪心)

程序员文章站 2024-01-03 11:15:22
...

Radar Installation

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 117779   Accepted: 25982

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

POJ-1328 Radar Installation(贪心)
Figure A Sample Input of Radar Installations


 

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

题目大意:以x轴为海岸线,上方为海,下方为陆地,海岸上的点表示雷达,海里的点表示岛屿,雷达的扫描区域为一个以该雷达为圆心半径为d的圆,问最少装多少个雷达可以使每个岛屿都被扫描到。

做题思路:可将问题转化为:求最少用多少个点可以使x轴上每个区间内都有一个点。

并且当y>d时,该岛屿没有满足的雷达。

POJ-1328 Radar Installation(贪心)

AC代码:

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <algorithm>
using namespace std;
struct node
{
    double left;
    double right;
};
double compute(double p,double q)
{
    double t=p*p-q*q;
    return sqrt(t);
}
bool cmp(node aa,node bb)
{
    if(aa.right<bb.right)
        return true;
    return false;
}
node a[1005];
int main()
{
//    freopen("in.txt","r",stdin);
    int n;
    double d;
    double x,y;
    bool flag;//记录是否有不满足的点
    int summ;//记录最少需要装的雷达数
    int k=0;
    while(~scanf("%d%lf",&n,&d)&&n&&d)
    {
        flag=false;
        for(int i=0; i<n; i++)//输入数据并算出每个岛屿的雷达范围
        {
            scanf("%lf%lf",&x,&y);
            if(y>d)
                flag=true;
            double x1=compute(d,y);
            a[i].left=x-x1;
            a[i].right=x+x1;
        }
        if(flag==true)
        {
            printf("Case %d: -1\n",++k);
            continue;
        }
        sort(a,a+n,cmp);//将结构体数组按照right从小到大排序
        int pos=0;//每次比较的位置
        summ=1;//初始为一个
        for(int i=1; i<n; i++) //遍历所有的区间
        {
            if(a[i].left<=a[pos].right)
                continue;
            else
            {
                pos=i;
                summ++;
            }
        }
        printf("Case %d: %d\n",++k,summ);
    }
    return 0;

}

如有不对,或者疏漏的点,还请各位大佬多多指教

上一篇:

下一篇: