1086 Tree Traversals Again (25分)
1 题目
1086 Tree Traversals Again (25分)
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
2 解析
- 题意:根据栈的出栈、入栈序列,输出二叉树的后序序列
- 思路:
- 入栈序列为先序序列,出栈序列为中序序列
- 1 根据先序和中序序列建立二叉树,然后后序遍历输出二叉树
3 参考代码
#include <cstdio>
#include <iostream>
#include <stack>
#include <string>
using std::cin;
using std::stack;
using std::string;
const int MAXN = 35;
int in[MAXN];
int pre[MAXN];
int N;
struct node
{
int data;
node* lchild;
node* rchild;
};
node* Create(int preL, int preR, int inL, int inR){
if(preL > preR){
return NULL;
}
node* root = new node;
root->data = pre[preL];
int k;
for (k = inL; k <= inR; ++k)
{
if(in[k] == root->data){
break;
}
}
int numLeft = k - inL;
root->lchild = Create(preL + 1, preL + numLeft, inL, k - 1);
root->rchild = Create(preL + numLeft + 1, preR, k + 1, inR);
return root;
}
int num = 0;
void postorder(node* root){
if(root == NULL){
return;
}
postorder(root->lchild);
postorder(root->rchild);
printf("%d", root->data);
num++;
if(num < N) printf(" ");
}
int main(int argc, char const *argv[])
{
scanf("%d", &N);
string str;
int temp, num,inCount = 0,preCount = 0;
stack<int> s;
for (int i = 0; i < 2 * N; ++i)
{
cin >> str;
if(str == "Push"){
scanf("%d", &num);
s.push(num);
pre[preCount++] = num;
}else{
temp = s.top();
s.pop();
in[inCount++] = temp;
}
}
node* root = Create(0, N - 1, 0, N - 1);
postorder(root);
return 0;
}
上一篇: 小米手环4使用体验及图文评测
推荐阅读
-
pat 1086 Tree Traversals Again
-
PATA 1086 Tree Traversals Again
-
浙大数据结构习题笔记:03-树3 Tree Traversals Again (25分)
-
【MOOC】03-树3 Tree Traversals Again (25分)
-
C语言 03-树3 Tree Traversals Again
-
【PAT】A1086 Tree Traversals Again (25分)
-
1086 Tree Traversals Again
-
PAT甲级1086 Tree Traversals Again (25分)|C++实现
-
1086. Tree Traversals Again (25)
-
PAT A1086 Tree Traversals Again (25分)