PAT A1086 Tree Traversals Again (25分)
原题
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:3 4 2 6 5 1
大体题意
中序遍历可以用栈进行非递归遍历,因此要求通过栈的活动得到树,并输出后序序列
思路
前序序列可以看成入栈
中序序列可以看成出栈
因此通过所给的输入,我们可以得到前序序列和中序序列
因此该题的本质就是通过前序和中序得到后序
代码
#include <iostream>
using namespace std;
#include <string>
#include <vector>
#include <stack>
vector<int> preorder, inorder;
stack<int>node;
struct Tree
{
int data;
Tree* lchild, * rchild;
};
Tree* createTree(int preL, int preR, int inL, int inR)
{
if (inL > inR)
return NULL;
Tree* t = new Tree;
t->data = preorder[preL];
int i;
for (i = inL; i < inR; ++i)
if (inorder[i] == preorder[preL])
break;
int numleft = i - inL;
t->lchild = createTree(preL + 1, preL + numleft, inL, i - 1);
t->rchild = createTree(preL + numleft + 1, preR, i + 1, inR);
return t;
}
bool first = false;
void postTravel(Tree* root)
{
if (root == NULL)
return;
postTravel(root->lchild);
postTravel(root->rchild);
if (first)
cout << " ";
cout << root->data;
first = true;
}
int main()
{
int n, a;
cin >> n;
string s;
for (int i = 0; i < 2 * n; i++)
{
cin >> s;
if (s == "Push")
{
cin >> a;
preorder.push_back(a);
node.push(a);
}
else
{
a = node.top();
node.pop();
inorder.push_back(a);
}
}
Tree* root = createTree(0, n - 1, 0, n - 1);
postTravel(root);
return 0;
}
运行结果
推荐阅读
-
1086 Tree Traversals Again (25 分)(二叉树的遍历)
-
pat 1086 Tree Traversals Again
-
PATA 1086 Tree Traversals Again
-
浙大数据结构习题笔记:03-树3 Tree Traversals Again (25分)
-
【MOOC】03-树3 Tree Traversals Again (25分)
-
C语言 03-树3 Tree Traversals Again
-
【PAT】A1086 Tree Traversals Again (25分)
-
1086 Tree Traversals Again
-
PAT甲级1086 Tree Traversals Again (25分)|C++实现
-
1086. Tree Traversals Again (25)