欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

【测试点0分析】1009 Product of Polynomials (25 分)

程序员文章站 2022-07-15 13:31:01
...

立志用最少的代码做最高效的表达


PAT甲级最优题解——>传送门


This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ … N​K​​ a​N​K​​​​where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:
3 3 3.6 2 6.0 1 1.6


测试点0:多项式相乘,可能出现系数为0的情况,因此,最后输出的项数可能计算错误。

解法:数组硬解, 其实换成结构体存储效率会高一点,但考虑到最大数据量只有1k,因此也无所谓了。


#include<bits/stdc++.h>
using namespace std;
typedef long long gg;

gg a[1010] = {0}, b[1010] = {0}, c[2020] = {0};  

int main() {
	gg k,x; cin >> k; while(k--) {
		cin >> x; double d; cin >> d;
		a[x] = (gg)(d*100);
	}
	cin >> k; while(k--) {
		cin >> x; double d; cin >> d;
		b[x] = (gg)(d*100);
	}
	gg num = 0;
	for(gg i = 0; i <= 1000; i++) 
		for(gg j = 0; j <= 1000; j++) {
			if(a[i] == 0) continue;
			if(b[j] != 0) c[i+j] += a[i]*b[j]; 
		}
	
	for(int i = 0; i <= 2000; i++) if(c[i] != 0) num++;
	
	printf("%d", num);
	for(int i = 2000; i >= 0; i--) 
		if(c[i] != 0) printf(" %d %.1lf", i, c[i]/10000.0);
	
	
	return 0;
} 

【测试点0分析】1009 Product of Polynomials (25 分)