PAT (Advanced Level) 1006 Sign In and Sign Out (25 分)
序:
老套路了,结构体+排序
At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.
Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.
Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.
Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133
题目概述:
找出最先到的人和最晚走的人
分析:
建立结构体,cmp排序
//经典结构体套路了,还有cmp排序
#include<bits/stdc++.h>
using namespace std;
struct person
{
string name;
int h1, m1, s1;
int h2, m2, s2;
}personlist[1010];
bool cmp1(person a, person b)
{
return (a.h1 != b.h1) ? (a.h1 < b.h1) : ((a.m1 != b.m1) ? (a.m1 < b.m1) : (a.s1 < b.s1));
}
bool cmp2(person a, person b)
{
return (a.h2 != b.h2) ? (a.h2 > b.h2) : ((a.m2 != b.m2) ? (a.m2 > b.m2) : (a.s2 > b.s2));
}
int main()
{
int m;
cin >> m;
for(int i = 0; i < m; i++)
{
cin >> personlist[i].name;
scanf("%d:%d:%d", &personlist[i].h1, &personlist[i].m1, &personlist[i].s1);
scanf("%d:%d:%d", &personlist[i].h2, &personlist[i].m2, &personlist[i].s2);
}
sort(personlist, personlist + m, cmp1);
cout << personlist[0].name << " ";
sort(personlist, personlist + m, cmp2);
cout << personlist[0].name << endl;
return 0;
}
总结:
string的输出时用cin可以省去很多麻烦。
推荐阅读
-
PAT 甲级真题 1006 Sign In and Sign Out (25分) python实现
-
PAT (Advanced Level) 1012 The Best Rank (25 分)
-
PAT (Advanced Level) Practice - 1122 Hamiltonian Cycle(25 分)
-
PAT (Advanced Level) 1009 Product of Polynomials (25 分)
-
PAT (Advanced Level) 1006 Sign In and Sign Out (25 分)
-
PAT_A1006 | Sign In and Sign Out
-
PAT (Advanced Level) Practice 1146 Topological Order (25分) (拓扑序列的判断)
-
1006.Sign in and Sign out(25)—PAT 甲级
-
PAT (Advanced Level) Practice - 1033 To Fill or Not to Fill(25 分)
-
PAT 甲级真题 1006 Sign In and Sign Out (25分) python实现