PAT (Basic Level) Practice 1014
题目
大侦探福尔摩斯接到一张奇怪的字条:我们约会吧! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm。大侦探很快就明白了,字条上奇怪的乱码实际上就是约会的时间星期四 14:04,因为前面两字符串中第 1 对相同的大写英文字母(大小写有区分)是第 4 个字母 D,代表星期四;第 2 对相同的字符是 E ,那是第 5 个英文字母,代表一天里的第 14 个钟头(于是一天的 0 点到 23 点由数字 0 到 9、以及大写字母 A 到 N 表示);后面两字符串第 1 对相同的英文字母 s 出现在第 4 个位置(从 0 开始计数)上,代表第 4 分钟。现给定两对字符串,请帮助福尔摩斯解码得到约会的时间。
输入格式
输入在 4 行中分别给出 4 个非空、不包含空格、且长度不超过 60 的字符串。
输出格式
在一行中输出约会的时间,格式为 DAY HH:MM,其中 DAY 是某星期的 3 字符缩写,即 MON 表示星期一,TUE 表示星期二,WED 表示星期三,THU 表示星期四,FRI 表示星期五,SAT 表示星期六,SUN 表示星期日。题目输入保证每个测试存在唯一解。
输入样例
3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm
输出样例
THU 14:04
思路
初次接触这条题目,感觉so easy,但当我提交代码的时候,现实给了我狠狠地一巴掌。之后,我调整了思路两次,但结果很让人伤心:一次得分不变,一次得分更低了。无奈之下,我只得百度大神的思路了。结果我发现,我™对题目的理解就是错的。哎,很烦,感觉要多去读读书了,理解能力不行。行了,废话不多说了,下面是解决本题需要注意的点:
1、求星期:第一个字符串与第二个字符串同时从索引为零的地方开始遍历,寻找对应位置字符相等且字符处在A ~ G范围内的,寻找到字符D,索引为6
2、求小时:第一个字符串与第二个字符串同时从索引为7(求星期得到的字符的下一位)的地方开始遍历,寻找对应位置字符相等且字符处在0 ~ 9或A ~ N范围内的,寻找到字符E
3、求分钟:第三个字符串与第四个字符串同时从索引为零的地方开始遍历,寻找到对应位置字符相等,且属于英文字母的(即,A ~ Z或 a ~ z范围内的)
代码
所有的代码均是原创,自行编写且通过PTA系统测试的,欢迎大家提建议!!!
#include <stdio.h>
#include <string.h>
#define MAXSIZE 61
#define N 4
void init(char (*str)[MAXSIZE],int *length);
void printStr(char (*str)[MAXSIZE],int *length);
void getDate(char (*str)[MAXSIZE],int *length,int *weekday,int *hour,int *minute);
void printDate(int weekday,int hour,int minute);
int main(){
char str[N][MAXSIZE];
int length[N];
init(str,length);
//printStr(str,length);
int weekday,hour,minute;
getDate(str,length,&weekday,&hour,&minute);
//printf("%d\n",weekday);
printDate(weekday,hour,minute);
return 0;
}
void init(char (*str)[MAXSIZE],int *length){
for(int i = 0;i < N;i++){
scanf("%s",*(str + i)); // 输入N个字符串
*(length + i) = strlen(*(str + i)); // 计算N个字符串的长度
}
}
void printStr(char (*str)[MAXSIZE],int *length){
for(int i = 0;i < N;i++){
printf("%s\n",*(str + i)); // 输出N个字符串
printf("%d\n",*(length + i)); // 输出N个字符串的长度
}
}
void getDate(char (*str)[MAXSIZE],int *length,int *weekday,int *hour,int *minute){
int startI,startJ;
for(int i = 0,j = 0;i < length[0] && j < length[1];i++,j++){ // 得到星期
if((str[0][i] == str[1][j]) && (str[0][i] >= 'A' && str[0][i] <= 'G')){
*weekday = str[0][i] - 'A' + 1;
startI = i;
break;
}
}
for(int i = startI + 1,j = startI + 1;i < length[0] && j < length[1];i++,j++){ // 得到小时
if((str[0][i] == str[1][j]) && ((str[0][i] >= 'A' && str[0][i] <= 'N') || (str[0][i] >= '0' && str[0][i] <= '9'))){
//printf("%c\n",str[0][i]);
if(str[0][i] >= '0' && str[0][i] <= '9'){
*hour = str[0][i] - '0';
}else{
*hour = str[0][i] - 'A' + 10;
}
break;
}
}
for(int i = 0,j = 0;i < length[2] && j < length[3];i++,j++){ // 得到分钟
if((str[2][i] == str[3][j]) && ((str[2][i] >= 'A' && str[2][i] <= 'Z') || (str[2][i] >= 'a' && str[2][i] <= 'z'))){
*minute = i;
break;
}
}
}
void printDate(int weekday,int hour,int minute){ // 输出约会时间
char weekdays[8][4] = {"none","MON","TUE","WED","THU","FRI","SAT","SUN"};
printf("%s %02d:%02d",*(weekdays + weekday),hour,minute);
}
上一篇: Mapped Statements collection does not contain value for XXX
下一篇: Mapped Statements collection does not contain value for
推荐阅读
-
PAT (Basic Level) Practice (中文)1001
-
1083 是否存在相等的差 PAT (Basic Level)
-
PAT (Basic Level) Practice (中文)1009 说反话 (20 分)
-
PAT (Basic Level) Practice 1009 说反话 (20 分)
-
PAT (Basic Level) Practice (中文)1009 说反话 (20)
-
PAT(basic-level)练习-1002
-
PAT (Advanced Level) Practice - 1122 Hamiltonian Cycle(25 分)
-
PAT Basic Level 1066 图像过滤 (15 分)
-
PAT (Basic Level) Practice (中文)1066 图像过滤 (15 分)(C实现)
-
1066 图像过滤 (15 分)—PAT (Basic Level) Practice (中文)