PAT (Basic Level) Practice (中文)1009 说反话 (20 分)
程序员文章站
2022-07-15 16:25:39
...
1009 说反话 (20 分)
给定一句英语,要求你编写程序,将句中所有单词的顺序颠倒输出。
输入格式:
测试输入包含一个测试用例,在一行内给出总长度不超过 80 的字符串。字符串由若干单词和若干空格组成,其中单词是由英文字母(大小写有区分)组成的字符串,单词之间用 1 个空格分开,输入保证句子末尾没有多余的空格。
输出格式:
每个测试用例的输出占一行,输出倒序后的句子。
输入样例:
Hello World Here I Come
输出样例:
Come I Here World Hello
乙级第四题这么水的吗???
// luogu-judger-enable-o2
#include<bits/stdc++.h>
#include<unordered_set>
#define rg register ll
#define inf 2147483647
#define min(a,b) (a<b?a:b)
#define max(a,b) (a>b?a:b)
#define ll long long
#define maxn 300005
#define lb(x) (x&(-x))
const double eps = 1e-6;
using namespace std;
inline ll read()
{
char ch = getchar(); ll s = 0, w = 1;
while (ch < 48 || ch>57) { if (ch == '-')w = -1; ch = getchar(); }
while (ch >= 48 && ch <= 57) { s = (s << 1) + (s << 3) + (ch ^ 48); ch = getchar(); }
return s * w;
}
inline void write(ll x)
{
if (x < 0)putchar('-'), x = -x;
if (x > 9)write(x / 10);
putchar(x % 10 + 48);
}
char s[100][85];
ll tot=0;
int main()
{
while(scanf("%s",s[++tot])!=EOF);
for(rg i=tot-1;i>=1;i--)
{
i==1?cout<<s[i]<<endl:cout<<s[i]<<" ";
}
return 0;
}
下一篇: HashMap的性能瓶颈
推荐阅读
-
PAT (Basic Level) Practice (中文)1009 说反话 (20 分)
-
PAT (Basic Level) Practice 1009 说反话 (20 分)
-
PAT (Basic Level) Practice (中文)1009 说反话 (20)
-
PAT (Basic Level) Practice (中文)1066 图像过滤 (15 分)(C实现)
-
1066 图像过滤 (15 分)—PAT (Basic Level) Practice (中文)
-
PAT (Basic Level) Practice (中文) 1066 图像过滤 (15分)
-
PAT (Basic Level) Practice (中文)1066 图像过滤 (15 分)
-
PAT (Basic Level) Practice (中文)1066 图像过滤 (15 分)
-
PAT (Basic Level) Practice (中文)1066 图像过滤 C语言版 (15分)
-
PAT (Basic Level) Practice (中文)1047 编程团体赛 (20 分)