PAT-A-1031 Hello World for U 【简单模拟】
Given any string of N (≥5) characters, you are asked to form the characters into the shape of U
. For example, helloworld
can be printed as:
h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U
to be as squared as possible -- that is, it must be satisfied that n1=n3=max { k | k≤n2 for all 3≤n2≤N } with n1+n2+n3−2=N.
Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.
Output Specification:
For each test case, print the input string in the shape of U as specified in the description.
Sample Input:
helloworld!
Sample Output:
h !
e d
l l
lowor
Tips:将字符串输出一个U字型,且竖着的长度小于等于横着的部分,注意,重叠的部分也要加进去。
#include<iostream>;
#include <string>
using namespace std;
int main(){
string data;
cin>>data;
int size=data.size();
int down=size/3;
int bottum=size%3;
if(bottum==0){
down-=1;
bottum=data.size()-2*down;
}else{
bottum+=down;
}
for (int i=0;i<down;i++){
printf("%c",data[i]);
for(int j=0;j<bottum-2;j++){
printf("%c",' ');
}
printf("%c\n",data[data.size()-(i+1)]);
}
for(int k=down;k<down+bottum;k++){
printf("%c",data[k]);
}
cout<<endl;
return 0;
}
推荐阅读
-
Docker搭建简单的应用栈与容器Hello World访问详解
-
eclipse rcp详解Hello World以及eclipse rcp和osgi的简单展示(图文)
-
Openresty服务器使用lua脚本写的Hello World简单实例
-
Spring MVC 简单的hello world的实现
-
PAT-A-1031 Hello World for U 【简单模拟】
-
初入JAVA Hello World and 简单语法规则
-
Docker搭建简单的应用栈与容器Hello World访问详解
-
PAT甲级 1031 Hello World for U 模拟
-
最简单的模拟U盘病毒(Autorun.inf)
-
创建一个简单的Hello World案例