欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

PAT-A-1093 Count PATs 【复习】

程序员文章站 2022-07-15 10:53:32
...

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

思路:

从左向右遍历,记录每个位置及左边P出现的次数

从右向左遍历,记录每个位置右边T出现的次数,如果是A,同时计算。

#include <iostream>
#include <vector>
#include <math.h>
#include <string>
using namespace std;
int main(){
	string data;
	int numOfLeftN[100001];
	cin>>data;
	int size=data.size();
	for(int i=0,t=0;i<size;i++){
		if(data[i]=='P') t++;
		numOfLeftN[i]=t;
	}
	
	long res=0;
	for(int j=size-1,x=0;j>=0;j--){
		if(data[j]=='T') x++;
		else if(data[j]=='A'){
			res+=(x*numOfLeftN[j])%1000000007;
		}
	}
	printf("%ld",res%1000000007);
return 0;
}

 PAT-A-1093 Count PATs 【复习】