1053 Path of Equal Weight(DFS)
Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.
Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where Wi(<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.
Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.
Note: sequence {A1,A2,⋯,An} is said to be greater than sequence {B1,B2,⋯,Bm} if there exists 1≤k<min{n,m} such that Ai=Bi for i=1,⋯,k, and Ak+1>Bk+1.
Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
AC代码
#include <vector>
#include <queue>
#include <algorithm>
#include <cstdio>
using namespace std;
const int maxv = 101;
struct node{
int id, weight;
};
vector<node> G[maxv]; //孩子结点
int w[maxv];
int n, m, s; //结点数 非叶结点数 给定权值
vector<int> path;
bool cmp(node a, node b){
return a.weight > b.weight;
}
void DFS(int u, int temp, int s){
if(temp > s) return;
if(temp == s){
if(G[u].size() != 0) return;
for(int i = 0; i < path.size(); i++){
printf("%d", path[i]);
if(i < path.size() - 1) printf(" ");
else printf("\n");
}
return;
}
for(int i = 0; i < G[u].size(); i++){
int v = G[u][i].id;
path.push_back(w[v]);
DFS(v, temp + w[v], s);
path.pop_back();
}
}
int main(){
scanf("%d%d%d", &n, &m, &s);
for(int i = 0; i < n; i++)
scanf("%d", w + i);
int pid, k, cid;
node tmp;
for(int i = 0; i < m; i++){
scanf("%d%d", &pid, &k);
for(int j = 0; j < k; j++){
scanf("%d", &cid);
tmp.id = cid;
tmp.weight = w[cid];
G[pid].push_back(tmp);
}
sort(G[pid].begin(), G[pid].end(), cmp);
}
path.push_back(w[0]);
DFS(0, w[0], s);
return 0;
}
上一篇: LeetCode - mysql【178. 分数排名】
下一篇: 178. 分数排名
推荐阅读
-
PAT A1053:Path of Equal Weight
-
(pat)A1053 Path of Equal Weight
-
PAT A1053 Path of Equal Weight(30 分)
-
PAT A1053 Path of Equal Weight (30分)
-
PAT甲级——A1053 Path of Equal Weight【30】
-
PAT甲级——A1053 Path of Equal Weight
-
1053 Path of Equal Weight (30 分)
-
1053 Path of Equal Weight (30 分)
-
1053 Path of Equal Weight (30 分)
-
1053 Path of Equal Weight (30分)