欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

PAT A1053 Path of Equal Weight(30 分)

程序员文章站 2022-07-07 20:16:13
...

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

PAT A1053 Path of Equal Weight(30 分)

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]


where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 2410 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 200 4 01 02 03 0402 1 0504 2 06 0703 3 11 12 1306 1 0907 2 08 1016 1 1513 3 14 16 1717 2 18 19

Sample Output:

10 5 2 7

10 4 10

10 3 3 6 2

10 3 3 6 2
代码如下:

package patA;

import java.util.Arrays;
import java.util.Collections;
import java.util.Comparator;
import java.util.Scanner;
import java.util.Vector;

public class A1053 {

	static int path[] = new int[100];// 记录路径
	static int number;// 记录总结点数

	static int notleaf;// 非叶子结点数

	static int mubiao;// 给定的值

	static int quanzhi[] = new int[100];
	// 结点数组
	static Node node[] = new Node[100];

	// 结点的类
	static class Node {
		int data;// 每个点的权值

		Vector<Integer> v = new Vector();// 存储孩子结点
	}

	// 深度遍历算法,index是结点编号,numNode是path路径上的结点个数,sum是path 上的结点和
	static void dfs(int index, int numNode, int sum) {
		
	
// 如果到跟结点前已经超过目标
		if(sum>mubiao) {
			
		
			return ;
		}else if(sum==mubiao) {
			
			
			
			
			if(node[index].v.size()!=0) {
				return ;
			}else{
				//到达了叶子结点,输出path
				for(int m=0;m<numNode;m++) {
					System.out.print(node[path[m]].data);
				}
			}
		}
		
		for(int h=0;h<node[index].v.size();h++) {
			int child=node[index].v.get(h);
			path[numNode]=child;
			dfs(child,numNode+1,sum+node[child].data);
		}
	}

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc = new Scanner(System.in);

		number = sc.nextInt();
		notleaf = sc.nextInt();
		mubiao = sc.nextInt();

		for (int i = 0; i < number; i++) {
			quanzhi[i] = sc.nextInt();
			node[i] = new Node();
			node[i].data=quanzhi[i];
		}
		// 初始化Node数组
		for (int i = 0; i < notleaf; i++) {
			int num = sc.nextInt();

			int numchild = sc.nextInt();
			for (int j = 0; j < numchild; j++) {
	
				node[num].v.add(sc.nextInt());

				// 对子节点按照从大到小排序
				Compaa compaa = new Compaa();
				Collections.sort(node[num].v, compaa);
			}

		}
		
		path[0]=0;
		dfs(0,1,node[0].data);

	}

}

class Compaa implements Comparator<Integer> {
	public int compare(Integer n1, Integer n2) {
		if (n1 > n2) {
			return -1;
		} else {
			return 1;
		}
	}
}

 

相关标签: PAT 算法