PAT A1053:Path of Equal Weight
题目描述
1053 Path of Equal Weight (30分)
Given a non-empty tree with root R, and with weight assigned to each tree node . The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.
Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree,
M (<N), the number of non-leaf nodes, and , the given weight number.
The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.
Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.
Note: sequence is said to be greater than sequence if there exists such that for i=1,…,k, and .
Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
求解思路
给定一棵树和每个结点的权值,求所有从根节点到叶子结点的路径,使得每条路径上的结点的权值之和等于给定的常数S。如果有多条这样的路径,则按路径非递增的顺序输出。
- 采用树结构,定义一个结构体node,用于存放结点的数据,以及指向其子节点的指针,因为子节点可能不止一个,所用用一个vector来存储每个结点的编号。因为最后的输出需要按照权值从大到小排序,所以在读入的时候可以实现对每个结点的子节点进行排序。这样就可以优先遍历每个子节点中权值更大的那个子节点
- 用一个vector容器path来保存递归过程中产生的路径上的结点编号。接下来进行DFS搜索,参数:当前访问的结点标号index、当前路径上的权值和sum。递归过程的伪代码如下:
- 若sum>S,直接return
- 若sum==S,说明到达当前访问结点index为止,输入中需要达到的S已经得到了。如果当前结点位叶子结点,则输出path中的所有数据,否则return
- 若sum<S,说明要求还没满足。此时枚举当前访问结点index的所有子节点,对每一个子节点child,先将其存入path中,然后在此基础上往下一层递归,下一层递归的参数为child,sum+node[child].weight
- 注意:使用vector存储路径的话,记得下一层回溯上来之后将前面加入的子节点pop_back出来
代码实现
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=10001;
struct Node{
int weight;
vector<int>child;
}node[maxn];
int n,m,s;
vector<int>path;
bool cmp(int a,int b) //根据结点值对结点进行排序
{
return node[a].weight>node[b].weight;
}
void DFS(int index,int sum)
{
if(sum>s) return;
else if(sum==s)
{
if(node[index].child.size()) return; //非叶子结点
else
{
for(int i=0;i<path.size();i++)
{
printf("%d",node[path[i]].weight);
if(i<path.size()-1) printf(" ");
else printf("\n");
}
}
}
else
{
for(int i=0;i<node[index].child.size();i++)
{
int child=node[index].child[i];
path.push_back(child);
DFS(child,sum+node[child].weight);
path.pop_back(); //下一层递归回溯上来之后将前面加入的子节点pop_back即可
}
}
}
void init()
{
// 用于数据读取与初始化
scanf("%d %d %d",&n,&m,&s);
for(int i=0;i<n;i++)
{
scanf("%d",&node[i].weight);
}
for(int i=0;i<m;i++)
{
int node_index,child_num;
scanf("%d %d",&node_index,&child_num);
for(int j=0;j<child_num;j++)
{
int child_index;
scanf("%d",&child_index);
node[node_index].child.push_back(child_index);
}
sort(node[node_index].child.begin(),node[node_index].child.end(),cmp);
}
}
void solve()
{
init();
path.push_back(0); //路径第一个结点设置为0号结点
DFS(0,node[0].weight);
}
int main()
{
solve();
return 0;
}
上一篇: 常见问题
下一篇: 获取HTTP请求数据
推荐阅读
-
PAT A1053:Path of Equal Weight
-
(pat)A1053 Path of Equal Weight
-
PAT A1053 Path of Equal Weight(30 分)
-
PAT A1053 Path of Equal Weight (30分)
-
PAT甲级——A1053 Path of Equal Weight【30】
-
PAT甲级——A1053 Path of Equal Weight
-
1053 Path of Equal Weight (30 分)
-
1053 Path of Equal Weight (30 分)
-
1053 Path of Equal Weight (30 分)
-
1053 Path of Equal Weight (30分)