洛谷--------P1204 [USACO1.2]挤牛奶Milking Cows
程序员文章站
2022-07-12 17:31:46
...
题目描述
三个农民每天清晨5点起床,然后去牛棚给3头牛挤奶。第一个农民在300秒(从5点开始计时)给他的牛挤奶,一直到1000秒。第二个农民在700秒开始,在 1200秒结束。第三个农民在1500秒开始2100秒结束。期间最长的至少有一个农民在挤奶的连续时间为900秒(从300秒到1200秒),而最长的无人挤奶的连续时间(从挤奶开始一直到挤奶结束)为300秒(从1200秒到1500秒)。
你的任务是编一个程序,读入一个有N个农民(1 <= N <= 5000)挤N头牛的工作时间列表,计算以下两点(均以秒为单位):
最长至少有一人在挤奶的时间段。
最长的无人挤奶的时间段。(从有人挤奶开始算起)
输入格式:
Line 1:
一个整数N。
Lines 2..N+1:
每行两个小于1000000的非负整数,表示一个农民的开始时刻与结束时刻。
输出格式:
一行,两个整数,即题目所要求的两个答案。
输入输出样例
输入样例#1: |
3 300 1000 700 1200 1500 2100 |
输出样例#1: |
900 300 |
代码:
#include<bits/stdc++.h>
using namespace std;
int n;
struct node
{
int begin,end;
}m[5010];
bool cmp(node a,node b)
{
return a.begin<b.begin;
}
int main()
{
int ans1=0,ans2=0;
scanf("%d",&n);
for(int i=1;i<=n;++i)
scanf("%d%d",&m[i].begin,&m[i].end);
sort(m+1,m+n+1,cmp);
int begin=m[1].begin;
int end=m[1].end;
for(int i=2;i<=n;++i)
{
if(m[i].begin<=end)
end=max(end,m[i].end);
else
{
ans1=max(ans1,end-begin);
ans2=max(ans2,m[i].begin-end);
begin=m[i].begin;
end=m[i].end;
}
}
ans1=max(ans1,end-begin);
printf("%d %d",ans1,ans2);
return 0;
}
推荐阅读
-
洛谷 P1204 [USACO1.2]挤牛奶Milking Cows(模拟)
-
【题解】Luogu P1204 [USACO1.2]挤牛奶Milking Cows
-
【洛谷P1204】【USACO1.2】挤牛奶Milking Cows
-
java P1204 [USACO1.2]挤牛奶Milking Cows
-
【模拟】洛谷 P1204 [USACO1.2]挤牛奶Milking Cows
-
洛谷--------P1204 [USACO1.2]挤牛奶Milking Cows
-
[USACO1.2]挤牛奶Milking Cows 差分
-
洛谷 1204 [USACO1.2]挤牛奶Milking Cows
-
P1204 [USACO1.2]挤牛奶Milking Cows(差分)