Matrix POJ - 2155
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].
Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.
Output
For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.
Sample Input
1 2 10 C 2 1 2 2 Q 2 2 C 2 1 2 1 Q 1 1 C 1 1 2 1 C 1 2 1 2 C 1 1 2 2 Q 1 1 C 1 1 2 1 Q 2 1
Sample Output
1 0 0 1
二维线段树
AC的C++程序如下:
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
const int N=1e3+10;
int tree[4*N][4*N];
int n,q;
void updatey(int kx,int y1,int y2,int ly,int ry,int ky)
{
if(y1<=ly&&y2>=ry)
{
tree[kx][ky]=!tree[kx][ky];
return;
}
int mid=(ly+ry)>>1;
if(y1<=mid) updatey(kx,y1,y2,ly,mid,ky<<1);
if(y2>mid) updatey(kx,y1,y2,mid+1,ry,ky<<1|1);
}
void updatex(int x1,int y1,int x2,int y2,int lx,int rx,int kx)
{
if(x1<=lx&&x2>=rx)
{
updatey(kx,y1,y2,1,n,1);
return;
}
int mid=(lx+rx)>>1;
if(x1<=mid) updatex(x1,y1,x2,y2,lx,mid,kx<<1);
if(x2>mid) updatex(x1,y1,x2,y2,mid+1,rx,kx<<1|1);
}
int qy(int kx,int y,int ly,int ry,int ky)
{
int cnt=0;
if(tree[kx][ky]) cnt++;
if(ly==ry)
{
return cnt;
}
int mid=(ly+ry)>>1;
if(y<=mid) cnt+=qy(kx,y,ly,mid,ky<<1);
else cnt+=qy(kx,y,mid+1,ry,ky<<1|1);
return cnt;
}
int qx(int x,int y,int lx,int rx,int kx)
{
int cnt=0;
cnt+=qy(kx,y,1,n,1);
if(lx==rx)
{
return cnt;
}
int mid=(lx+rx)>>1;
if(x<=mid) cnt+=qx(x,y,lx,mid,kx<<1);
else cnt+=qx(x,y,mid+1,rx,kx<<1|1);
return cnt;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&q);
memset(tree,0,sizeof(tree));
while(q--)
{
char str[2];
scanf("%s",str);
if(str[0]=='C')
{
int x1,y1,x2,y2;
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
updatex(x1,y1,x2,y2,1,n,1);
}
else
{
int x,y;
scanf("%d%d",&x,&y);
int ans=qx(x,y,1,n,1);
printf("%d\n",ans%2);
}
}
if(t) printf("\n");
}
return 0;
}