欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU 4310 Hero【贪心】

程序员文章站 2022-07-12 12:17:40
...

Hero

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 6757 Accepted Submission(s): 2852

Problem Description

When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero’s HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.

Input

The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)

Output

Output one line for each test, indicates the minimum HP loss.

Sample Input

1
10 2
2
100 1
1 100

Sample Output

20
201

Author

TJU

Source

2012 Multi-University Training Contest 2

题意: 一个人打怪,自己有无限的血量,但是伤害只有1点,要打n个怪,打怪是按照回合制的,每次你只能选择一个怪,伤害1个血量,所有活着的怪都会打你,如果某一个怪的血量为0,就死了,给出每个怪的血量和伤害值,问你最少减少多少血量。

分析: 说白了就是让你求个打怪的顺序,贪心地按照怪的伤害比来计算即可,什么是伤害比呢,就是伤害比上血量,谁的伤害比越大就先打谁。

参考代码

#include<bits/stdc++.h>

using namespace std;

struct f{
    int dead;
    int score;
}a[1010];

bool cmp(f x,f y) {
    return x.score > y.score || (x.score == y.score && x.dead < y.dead);
}
bool vis[1010];

int main(){
    ios_base::sync_with_stdio(0);
    int T;cin>>T;
    while(T--) {
        memset(vis,false,sizeof(vis));
        vis[0] = true;
        int n;cin>>n;
        for(int i = 0;i < n;i++)
            cin>>a[i].dead;
        for(int i = 0;i < n;i++)
            cin>>a[i].score;
        sort(a,a+n,cmp);
        int res = 0;
        for(int i = 0;i < n;i++) {
            int t = a[i].dead;
            while(true) {
                if(t == 0) {
                    res += a[i].score;
                    break;
                }
                if(!vis[t]) {
                    vis[t] = true;
                    break;
                }
                t--;
            }
        }
        cout<<res<<endl;
    }
    return 0;
}
  • 如有错误或遗漏,请私聊下UP,thx
相关标签: 贪心 贪心算法