PAT 1146 Topological Order(25 分)
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
思路:每次判断时用重新声明一个数组,存储度的信息。
程序:
#include <cstdio>
#include <iostream>
#include <vector>
#include <cstring>
using namespace std;
int edge[1001][1001];
int degree[1001];
bool isTopo(vector<int> v,int* deg)
{
for(int i = 0; i < v.size(); i++)
{
if(deg[v[i]] == 0)
{
for(int j = 1; j <= v.size(); j++)
{
if(edge[v[i]][j])
deg[j]--;
}
}
else
return false;
}
return true;
}
int main()
{
int n,m;
scanf("%d%d",&n,&m);
for(int i = 0; i < m; i++)
{
int a,b;
scanf("%d%d",&a,&b);
edge[a][b] = 1;
degree[b]++;
}
int k;
scanf("%d",&k);
vector<int> v;
vector<int> cnt;
for(int i = 0; i < k; i++)
{
v.clear();
for(int j = 0; j < n; j++)
{
int point;
scanf("%d",&point);
v.push_back(point);
}
int arr[1001];
memcpy(arr,degree,sizeof(degree));
if(!isTopo(v,arr))
{
cnt.push_back(i);
}
}
for(int i = 0; i < cnt.size(); i++)
{
if(i == 0)
printf("%d",cnt[i]);
else
printf(" %d",cnt[i]);
}
return 0;
}
上一篇: 7-5 螺旋方阵 (20分) 所谓“螺旋方阵”,是指对任意给定的N,将1到N×N的数字从左上角第1个格子开始,按顺时针螺旋方向顺序填入N×N的方阵里。本题要求构造这样的螺旋方阵。
下一篇: 1019 数字黑洞 (20分)
推荐阅读
-
【PAT】B1085 PAT单位排行(25 分)(c++实现)
-
PAT 甲级真题 1006 Sign In and Sign Out (25分) python实现
-
PAT (Advanced Level) 1012 The Best Rank (25 分)
-
PAT甲1122 Hamiltonian Cycle(25 分)
-
[Python](PAT)1122 Hamiltonian Cycle(25 分)
-
PAT (Advanced Level) Practice - 1122 Hamiltonian Cycle(25 分)
-
PAT (Advanced Level) 1009 Product of Polynomials (25 分)
-
【PAT甲级】【1002】 A+B for Polynomials (25分)
-
PAT (Advanced Level) 1006 Sign In and Sign Out (25 分)
-
PAT(A)1025 PAT Ranking (25分)